Missing jq package v1.6

Asked by Sean Fausett on 2019-09-24

It's been over a year since jq v1.6 was released, but it's still not available on Ubuntu [Bionic] for some reason. Why is that?

References:
- https://github.com/stedolan/jq/releases
- https://stedolan.github.io/jq/download
- https://packages.ubuntu.com/bionic/jq

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu jq Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-09-30
Last query:
2019-09-30
Last reply:
2019-09-24
Manfred Hampl (m-hampl) said : #1

Manfred Hampl suggests this article as an answer to your question:
FAQ #3037: “no rolling release”.

Best Manfred Hampl (m-hampl) said : #2

Additionally you have to be aware that Ubuntu is taking over packages from Debian (to avoid double packaging work), and according to https://packages.debian.org/search?keywords=jq&searchon=names&exact=1&suite=all&section=all also Debian has only version 1.5 in unstable and testing.

First step for bringing jq 1.6 into Ubuntu is creating a bug report in Debian, and another bug report in Ubuntu with a link to the Debian bug.

I suggest you report a bug. If the bug and security fixes are significant then the package will be updated sooner rather than later.

There may be a PPA here on Launchpad.

Sean Fausett (openfool) said : #4

Thanks Manfred Hampl, that solved my question.