Activate driver from command line

Asked by Anders Eide on 2009-03-13

Is there some way to do this from a command line? Like from a bash script or something

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu jockey Edit question
Assignee:
No assignee Edit question
Solved by:
Anders Eide
Solved:
2009-03-13
Last query:
2009-03-13
Last reply:
2009-03-13

What kind of drivers?

Anders Eide (anders-eide) said : #2

I found the solution

jockey-gtk -e DRIVER

To find the DRIVER i did first run

jockey-gtk -c

then

jockey-gtk -l

Thomasapage (tomassapage) said : #3

is this that i need to do to have my ATI driver ready to use?
Thank's
;)

Thomasapage (tomassapage) said : #4

Sorry!!!
Is this what i need to do...
I'm not English...
I'm doing that and I'm having an error...

thomas@thomas-laptop:~$ jockey-gtk -c
ERROR:dbus.proxies:Introspect error on :1.179:/DeviceDriver: dbus.exceptions.DBusException: org.freedesktop.DBus.Error.NoReply: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken

Jukka Merinen (jmerinen) said : #5

I'm trying to enable a driver to a set of workstations using a shell script. Is there any way to change the display driver using jockey from the command-line, without being inside an X session?

If I type the command

root@test:~# jockey-gtk --enable xorg:nvidia-180

it works fine if I'm in a terminal under an X session, but when using non-X session it gives the following errors:

/var/lib/python-support/python2.6/gtk-2.0/gtk/__init__.py:72: GtkWarning: could not open display
  warnings.warn(str(e), _gtk.Warning)
/usr/bin/jockey-gtk:51: Warning: invalid (NULL) pointer instance
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: Warning: g_signal_connect_data: assertion `G_TYPE_CHECK_INSTANCE (instance)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: GtkWarning: gtk_settings_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: Warning: g_object_get: assertion `G_IS_OBJECT (object)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: GtkWarning: gdk_pango_context_get_for_screen: assertion `GDK_IS_SCREEN (screen)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: PangoWarning: pango_context_set_font_description: assertion `context != NULL' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: PangoWarning: pango_context_set_base_dir: assertion `context != NULL' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: PangoWarning: pango_context_set_language: assertion `context != NULL' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: Warning: g_object_unref: assertion `G_IS_OBJECT (object)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: GtkWarning: gdk_screen_get_display: assertion `GDK_IS_SCREEN (screen)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
/usr/bin/jockey-gtk:51: GtkWarning: gdk_keymap_get_for_display: assertion `GDK_IS_DISPLAY (display)' failed
  self.glade = gtk.glade.XML('/usr/share/jockey/main.glade')
Segmentation fault