Server 11.04 AMD - Jockey from CLI for BCM4318?

Asked by Monton on 2011-07-11

I am attempting to install "product: BCM4318 [AirForce One 54g] 802.11g Wireless LAN Controller" on an 11.04 AMD box.

So far I have tried:

apt-get upgrade; apt-get dist-remove -y; apt-get purge -y; apt-get autoremove -y;
apt-get install b43-fwcutter firmware-b43-installer -y;
shutdown now -r
lshw -C network;

ifconfig displays wired, hamachi and loopback.

lshw -C network -- shows the Wifi as being UNCLAIMED still.

modprobe -r b43 ssb wl
modprobe wl

According to : https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx it is "b43 - BCM4306/3, BCM4311, BCM4312, BCM4318, BCM4320 "

apt-get install bcmwl-kernel-source -y; shutdown now -r;

Step 1.

To install b43-fwcutter issue the following command in a terminal (under the desktop menu Applications > Accessories > Terminal) and follow the prompts:

~$ sudo apt-get install b43-fwcutter

Since Ubuntu 11.04 Natty Narwhal additional installation of the package firmware-b43-installer can be helpful and/or necessary, respectively:

~$ sudo apt-get install b43-fwcutter firmware-b43-installer firmware-b43legacy-installer

Step 2.

Under the desktop menu System > Administration > Hardware/Additional Drivers, the b43 drivers can be activated for use.

For Step 2, this box has no GUI. Jockey-GTK will not run because of no GUI. Is there a way to enable the "restricted drivers" by CLI?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu jockey Edit question
Assignee:
No assignee Edit question
Last query:
2011-07-12
Last reply:
2011-07-12

You don't actually need a GUI to run jockey-gtk. You can pass it command-line arguments, and it will act as a command-line program. Run "jockey-gtk --help" (without the quotes) to list the commands you can use.

Monton (carldavidbrown) said : #2

With out a GUI, Jockey-gtk -c / -l ... etc gives errors instead of working.

Without Jockey is there anyway to enable the restricted drivers?

"# jockey-gtk -c
Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 27, in <module>
    from gi.repository import GdkPixbuf, Gtk, Notify
  File "/usr/lib/python2.7/dist-packages/gi/importer.py", line 76, in load_module
    dynamic_module._load()
  File "/usr/lib/python2.7/dist-packages/gi/module.py", line 249, in _load
    overrides_modules = __import__('gi.overrides', fromlist=[self._namespace])
  File "/usr/lib/python2.7/dist-packages/gi/overrides/Gtk.py", line 1251, in <module>
    raise RuntimeError("Gtk couldn't be initialized")
RuntimeError: Gtk couldn't be initialized"

Ubfan (ubfan1) said : #3

The open b43 driver and open b43 firmware should both work for your 4318 chip. Since this is 11.04, I recommend avoiding the proprietary Broadcom STA (aka wl) driver. Check the bug reports if you really want the wl driver, -- didn't work under Natty last time I tried. Determine which firmware(s) you have installed:
ls /lib/firmware/b43
ls /lib/firmware/b43-open
You should be good if either or both directories are present. If both are present, the b43 will be the one used.
The first installation (or first after a "sudo apt-get purge b43-fwcutter) when on a wired connection should offer to download Broadcom files, accept this, and the /lib/firmware/b43 files should be installed.
The installation of the firmware-b43-installer should install the /lib/firmware/b43-open files.

The installation of the bcmwl... package probably blacklisted the b43 driver. I'd simply purge that package, and check that no leftover blacklists exist in /etc/modprobe.d. The blacklist b43 instruction may be in a separate file, or added to the file blacklist.conf.

A reboot should load modules b43 and ssb with no effort on your part, and the wl module should not be present.

Can you help with this problem?

Provide an answer of your own, or ask Monton for more information if necessary.

To post a message you must log in.