jockey-gtk fails to start with PermissionDeniedByPolicy exception

Asked by Anthony Yeh on 2011-01-15

I am on Ubuntu 10.10.

When I try to run the "Additional Drivers" Administration panel, nothing happens when I click on it.

If I run jockey-gtk from the terminal, I just get the error shown at the bottom of this message. It doesn't help if I use sudo or gksu.

I did some searching and other people had this problem due to broken or missing Python packages, but my error message doesn't have any failed imports and following the recommended package reinstallations didn't help.

Following the advice of another thread I found related to jockey-gtk, I enabled logging on the jockey-backend and saw this when trying to run jockey-gtk:

DEBUG: _check_polkit_privilege: sender :1.69 on connection <dbus._dbus.SystemBus (system) at 0x9e4e4ac> pid 4753 is not authorized for com.ubuntu.devicedriver.info: dbus.Dictionary({}, signature=dbus.Signature('ss'))

I recalled reading somewhere that permissions can be set in the "Users and Groups" admin panel, by right clicking on a user and clicking Properties. However, when I right click a user and select Properties, nothing happens. There are no messages printed to the terminal.

Anyone got any ideas?

Thanks,
Anthony

-----------------------------------------------------------
$ gksu jockey-gtk
Exception in thread thread_call_progress_dialog:
Traceback (most recent call last):
  File "/usr/lib/python2.6/threading.py", line 532, in __bootstrap_inner
    self.run()
  File "/usr/lib/python2.6/threading.py", line 484, in run
    self.__target(*self.__args, **self.__kwargs)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
DBusException: com.ubuntu.DeviceDriver.PermissionDeniedByPolicy: com.ubuntu.devicedriver.info

Traceback (most recent call last):
  File "/usr/bin/jockey-gtk", line 420, in <module>
    sys.exit(u.run())
  File "/usr/lib/python2.6/dist-packages/jockey/ui.py", line 448, in run
    self.ui_show_main()
  File "/usr/bin/jockey-gtk", line 101, in ui_show_main
    self.update_tree_model()
  File "/usr/bin/jockey-gtk", line 277, in update_tree_model
    for h_id in self.get_displayed_handlers():
  File "/usr/lib/python2.6/dist-packages/jockey/ui.py", line 793, in get_displayed_handlers
    return self.backend().available(self.argv_options.mode)
  File "/usr/lib/pymodules/python2.6/dbus/proxies.py", line 140, in __call__
    **keywords)
  File "/usr/lib/pymodules/python2.6/dbus/connection.py", line 620, in call_blocking
    message, timeout)
dbus.exceptions.DBusException: com.ubuntu.DeviceDriver.PermissionDeniedByPolicy: com.ubuntu.devicedriver.info
-----------------------------------------------------------

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu jockey Edit question
Assignee:
No assignee Edit question
Solved by:
Anthony Yeh
Solved:
2011-01-15
Last query:
2011-01-15
Last reply:

Have you logged a bug?

Anthony Yeh (enisoc) said : #2

I found the problem. It was actually due to policykit-1 being completely broken on my system. pkaction returned zero results, instead of listing all available actions. I eventually found out that for some reason (probably due to upgrading ubuntu in-place) I was missing files in /etc/polkit-1/localauthority.conf.d/ and /etc/polkit-1/nullbackend.conf.d/. Both of those directories were completely empty on my system.

As a result, policykit-1 never even loaded the files in /usr/share/polkit-1/actions and was not aware of any actions at all. I did some searching and added the following files as they apparently should have been:

/etc/polkit-1/localauthority.conf.d/50-localauthority.conf:
[Configuration]
AdminIdentities=unix-user:0

/etc/polkit-1/localauthority.conf.d/51-ubuntu-admin.conf:
[Configuration]
AdminIdentities=unix-grou:admin

/etc/polkit-1/nullbackend.conf.d/50-nullbackend.conf:
[Configuration]
Priority=-10

After rebooting, jockey-gtk works fine. Also, it fixed my problem of not being able to access the Permissions window in the Users Admin panel.