[Karmic] Repositories missing OpenJDK 1.5

Asked by Wes Garner

Binary package hint: default-jdk

The package introduced can be ignored as this is not concerning what is default (LaunchPad just required it)

An older version of Java is still required by many (even Google/Google Android still requires 5)
Can that package be included in the Karmic repositories or what kind of work around can be done

Question information

English Edit question
Ubuntu java-common Edit question
No assignee Edit question
Solved by:
Wes Garner
Last query:
Last reply:

This question was originally filed as bug #423499.

Revision history for this message
Bhavani Shankar (bhavi) said :

as the feature freeze now we arent open to new features right now... So I d suggest waiting till karmic +1 devel cycle begins


Revision history for this message
Onkar Shinde (onkarshinde) said :

1. OpenJDK 1.5 does not exist. So it can not be included in Ubuntu.
2. JDK/JRE is usually backwards compatible. So you can run programs that require 1.5 version of JRE with OpenJDK.
3. In case above does not work for you, you can use Sun JDK/JRE 1.5 which is available in multiverse repository.

Revision history for this message
Wes Garner (wesgarner) said :

Good point about OpenJDK - my bad there
Sun JDK/JRE 1.5 is not available under the Karmic repositories (multiverse included)
Sorry, that is what I really meant

Revision history for this message
Onkar Shinde (onkarshinde) said :

You are right about Sun JDK/JRE 1.5. It seems to have been removed from repositories. But you still have 1.6. But as I said you can very run 1.5 programs with 1.6.
So unless the program you want to run uses some feature that has been removed from 1.6 (which means it was deprecated since 1.4), you should not have problem.

Revision history for this message
Wes Garner (wesgarner) said :

Problem is Google Android Source requires 1.5 because of some faults with @Override
I just added the Jaunty multiverse - all is good