screen refreshes every 5 seconds, error appears to be 'segfault and nautilus'

Asked by Sandy Culver

In 10.04.1 with standard updates, I get a screen refresh every 5 seconds and top shows nautilus restarting all the time.

Machine is older Shuttle running Athlon 64 which had been stable and regularly updated for many months.

error in log:

ep 23 13:12:01 sandy-desktop kernel: [ 1156.103359] nautilus[5316]: segfault at 7f43c16e5bf0 ip 00007f43b7ae1e1c sp 00007f43c16e5bf0 error 6 in[7f43b7ab7000+4c000]

Ran Memtest, no errors

Stepped back one kernel to 2.6.32-23 and no change.

What to try next?

Question information

English Edit question
Ubuntu jasper Edit question
No assignee Edit question
Solved by:
Sandy Culver
Last query:
Last reply:

This question was reopened

Revision history for this message
Sandy Culver (sculver) said :

Also reachable on IRC as "culseg"

Revision history for this message
Sandy Culver (sculver) said :

Still stuck.

File Manager restarts every 4-5 seconds after icons and desktop disappears.

Used Update Manger, no change.

Have found only one virus file via clamscan, but clamscan gets stuck at /sys i8044 files.

Any ideas?

Revision history for this message
Sandy Culver (sculver) said :

also dmegs:

27310.421722] nautilus[5305]: segfault at 7f01adf86bf0 ip 00007f01a3b7be1c sp 00007f01adf86bf0 error 6 in[7f01a3b51000+4c000]
[27317.651100] nautilus[5328]: segfault at 7f2419845bf0 ip 00007f2412380e1c sp 00007f2419845bf0 error 6 in[7f2412356000+4c000]
[27324.977985] nautilus[5355]: segfault at 7f418d08dbf0 ip 00007f418cc52e1c sp 00007f418d08dbf0 error 6 in[7f418cc28000+4c000]

Revision history for this message
Sandy Culver (sculver) said :

What log files would be helpful to diagnose this problem?

Andy ideas to return my desktop to normal?



Revision history for this message
Sandy Culver (sculver) said :

pstree output:

Describe your new note here.init─┬─NetworkManager─┬─dhclient
     │ └─{NetworkManager}
     │ │ ├─bash───pstree
     │ │ ├─gnome-pty-helpe
     │ │ └─{gnome-terminal}
     │ └─{gksu}
     │ │ ├─hald-addon-inpu
     │ │ └─hald-addon-stor
     │ └─{hald}
     │ └─ck-launch-sessi───x-session-manag─┬─blue+
     │ ├─comp+
     │ ├─evol+
     │ ├─gdu-+
     │ ├─gnom+
     │ ├─gnom+
     │ ├─naut+
     │ ├─nm-a+
     │ ├─polk+
     │ ├─pyth+
     │ ├─seah+
     │ ├─upda+
     │ └─{x-s+
     │ └─{pulseaudio}
     │ └─{udisks-daemon}

Revision history for this message
Sandy Culver (sculver) said :

Using System Monitor have 'stopped' Nautilus and my screen has not refreshed for about 12 hours.

Installed Thunar to have a file manager.

Previous attempts to solve this nagging segfault problem include removing nautilus and using recover login to rebuild packages.

One helpful IRC person sent a shell script that might capture what nautilus is doing when 4-5 second restarts happen, which I will see if I can test.

Revision history for this message
Sandy Culver (sculver) said :

As strangely as this problem began, so it appears to have ended. After a day or so of having Nautilus stopped, it launched when I was trying to view a USB stick.

I will give it one more day before I close out this help request.

Revision history for this message
marcobra (Marco Braida) (marcobra) said :

Please tell do you have some nautilus extension installed ?

From terminal

dpkg -l | grep -i nautilus

Revision history for this message
Sandy Culver (sculver) said :

Thanks, it appears I do have nautilus extension:

ii libnautilus-burn4 2.25.3-0ubuntu4 Nautilus Burn Library - runtime version
ii libnautilus-extension1 1:2.30.1-0ubuntu1.1 libraries for nautilus components - runtime
ii nautilus 1:2.30.1-0ubuntu1.1 file manager and graphical shell for GNOME
ii nautilus-data 1:2.30.1-0ubuntu1.1 data files for nautilus
ii nautilus-sendto 2.28.4-0ubuntu1 integrates Evolution and Pidgin into the Nau
ii nautilus-sendto-empathy 2.30.2-0ubuntu1 GNOME multi-protocol chat and call client (n
ii nautilus-share 0.7.2-12build1 Nautilus extension to share folder using Sam

Revision history for this message
Sandy Culver (sculver) said :

Problem solved, not at all sure why.

Nautilus continues to work so closing this out for now.

After stable system for a day, I updated to MM 10-10 at 10PM for good measure, and all seem okay.

Revision history for this message
Sandy Culver (sculver) said :

Now just after Update Manager completed updates, main screen refreshes every few seconds and log files fill up:

last few lines of dmesg:

 2273.211358] nautilus[9224]: segfault at 7fb1f54d0ab0 ip 00007fb1f50b0e1c sp 00007fb1f54d0ab0 error 6 in[7fb1f5086000+4c000]
[ 2279.578671] nautilus[9239]: segfault at 7f7ebea3eab0 ip 00007f7e96434e1c sp 00007f7ebea3eab0 error 6 in[7f7e9640a000+4c000]

I have stopped nautilus via system monitor and since no certain cause or resolution was clear before, am reopening old trouble ticket for hopes of help.

Revision history for this message
delance (olivier-delance) said :

Could you check behavior with extension removed ?

Revision history for this message
Sandy Culver (sculver) said :


Thanks for an idea to test:

To be clear, which nautilus extension should I remove?

In Synaptic Package Manager I see a few options, and several nautilus extensions that I have not installed, such as for pastbin and file extension correction.

Revision history for this message
delance (olivier-delance) said :

Remove all extensions you can to make situation cleaner. And it it works, reintroduce extension one by one.

Revision history for this message
Sandy Culver (sculver) said :

Thanks. Didn't work.

I removed all extensions, still get constant screen refresh.

Also removed all Nautilus, lost Ubuntu-desktop, went to recover state and apt-get reinstalled desktop only to find exact same segfault error returns.

I would greatly appreciate any new ideas to try within my skill and knowledge level.

Revision history for this message
delance (olivier-delance) said :

Have a look at . If one bug matches your issue, subscribe it and link this question to the bug. Else open a new one.
Do you use JPEG2000 pictures ?

Revision history for this message
Sandy Culver (sculver) said :

Clever finding re JPEG2000!

I don't normally use that format, but searched and found one .jp2 on my desktop and after trying to open it using Gimp and not succeeding, Nautilus stopped refreshing.

Reinstalled Nautilis extensions and all is well.

Thank you 'delance'

Revision history for this message
thandermax (aniruddha-aot) said :

Happend to me today for a specific folder.

Similar stack trace:
May 9 20:13:17 ubuntu kernel: [ 326.119672] nautilus[3492]: segfault at 7fd5638b3000 ip 00007fd561cec414 sp 00007fd56389b1c0 error 6 in[7fd561cc5000+4c000]
May 9 20:13:30 ubuntu kernel: [ 338.825941] nautilus[3622]: segfault at 7effebe981c0 ip 00007effea798414 sp 00007effebe981c0 error 6 in[7effea771000+4c000]
May 9 20:14:02 ubuntu kernel: [ 371.400333] nautilus[3830]: segfault at 7f0c87f941c0 ip 00007f0c87b53414 sp 00007f0c87f941c0 error 6 in[7f0c87b2c000+4c000]
May 9 20:14:24 ubuntu kernel: [ 392.837835] nautilus[3956]: segfault at 7f63c40791c0 ip 00007f63c219d414 sp 00007f63c40791c0 error 6 in[7f63c2176000+4c000]

It happend while I opened my old Windows partition's folder (having a symbolic link to it, it might not be linked).
The folder contains a large no of items (mostly documents, images, pdf etc)

Somehow the libJasper failed to parse the image/icon of those items.

Its very sporadic error, happening only on that folder (in my case).
Stacktrace points to same offset : 4c000

Platform: Linux ubuntu 2.6.38-8-generic #42-Ubuntu SMP Mon Apr 11 03:31:24 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux

Anybody need more information on this ?