JACK audio won't start.

Asked by Robomaster on 2009-05-02

When I try to start the JACK audio server, I get a error saying it can't start. The messages are as follows:

17:39:17.707 Patchbay deactivated.
17:39:17.938 Statistics reset.
17:39:17.952 Startup script...
17:39:17.952 artsshell -q terminate
17:39:17.957 ALSA connection graph change.
sh: artsshell: not found
17:39:18.488 Startup script terminated with exit status=32512.
17:39:18.488 JACK is starting...
17:39:18.489 /usr/bin/jackd -R -dalsa -dhw:0 -r44100 -p1024 -n2
17:39:18.501 JACK was started with PID=5212.
no message buffer overruns
jackd 0.116.1
Copyright 2001-2005 Paul Davis and others.
jackd comes with ABSOLUTELY NO WARRANTY
This is free software, and you are welcome to redistribute it
under certain conditions; see the file COPYING for details
JACK compiled with System V SHM support.
cannot use real-time scheduling (FIFO at priority 10) [for thread -1212229952, from thread -1212229952] (1: Operation not permitted)
cannot create engine
17:39:18.792 JACK was stopped successfully.
17:39:18.793 Post-shutdown script...
17:39:18.793 killall jackd
17:39:18.795 ALSA connection change.
jackd: no process killed
17:39:19.199 Post-shutdown script terminated with exit status=256.
17:39:21.033 Could not connect to JACK server as client. - Overall operation failed. - Unable to connect to server. Please check the messages window for more info.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu jack-audio-connection-kit Edit question
Assignee:
No assignee Edit question
Solved by:
Robomaster
Solved:
2009-05-04
Last query:
2009-05-04
Last reply:
Robomaster (thebenjaminz) said : #1

Does ANYBODY have an answer for this? I desperately need to know!

treetaxi (treetaxi) said : #2

Why is this question marked "solved" ?? I'm using ubuntu lynx and all JACK does is turn off the audio applications that previously worked until I reboot the machine. The documentation on the home-page largely consists of "coming soon" and information for developers. It may be the greatest audio application since the telephone, but without simple instructions on how to hook up _application_ -> _JACK_ -> speaker, we're toasting marshmallows without a stick here. (a painful experience). Without the necessary instructions, this never should have been included as the default in an LTS distro.

fhaber (fhaber) said : #3

Yes, bump. Should not be marked as solved.