installing iscsitarget on ubuntu 12.04: FATAL: Module iscsi_trgt not found

Asked by Steve Page

After upgrading my Ubuntu Server running 12.04 LTS, to the latest "Hardware Enablement Stack", the iscsitarget service was no longer functional.

After some troubleshooting, it became apparant that during the installation or reinstallation of "iscsitarget-dkms", there is problems compiling "driver" for this module.

The error produced by the iscsitarget service is thus: FATAL: Module iscsi_trgt not found

Following a bug report here on launchpad, suggestions to fall back to a previous version were not successful. This bug report can be found here:

however, it is listed as fix-released. but I am not having success getting it workig.

Any ideas on if this is a bug? if so, any reccomendations for a work around?

Should this be filed as a bug report?

For more information on my issue, including output from "make.log", you can see this question askubuntu:

Question information

English Edit question
Ubuntu iscsitarget Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best actionparsnip (andrew-woodhead666) said :

Then post on the bug. You don't need to add a separate question as well. Keep all discussion in one place

Revision history for this message
Steve Page (stedor7) said :

Thanks actionparsnip, that solved my question.