Ubuntu not installing on XPS15

Asked by mohamad on 2018-05-14

I downloaded the Ubuntu iso and did all the step for a bootable usb
it reaches the ubuntu loading screen and then is stuck there
The usb works since I used it to install ubuntu on another old laptop
I tried to check the disk and it is telling me that the intel microcode is missing
what can I do to make it work? I tried the 18 and 16 version of ubuntu but both didn't work

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu intel-microcode Edit question
Assignee:
No assignee Edit question
Last query:
2018-05-14
Last reply:
2018-05-23

Hi Mohamed,

I also have a Dell XPS 15 and struggled with the same issues as you did. I followed the instructions below and everything worked out fine. The link below is for Mint but also works fine with Ubuntu!. Please check your exact Dell model because of BIOS update. I had to download a more recent version because I have a 9560 instead of a 9550.

Step 1 to get across the logo stuck (nomodeset)
http://www.dell.com/support/article/us/en/19/sln306327/manual-nomodeset-kernal-boot-line-option-for-linux-booting?lang=en

Step 2 installation

http://forum.notebookreview.com/threads/linux-mint-18-1-on-dell-xps-15-9550-i7-6700hq-1tb-ssd-uhd-4k-touch.800703/

Good luck.

Bart

Can you help with this problem?

Provide an answer of your own, or ask mohamad for more information if necessary.

To post a message you must log in.