Intel Microcode Update for 406F1

Asked by JT on 2018-04-11

I have an Intel Xeon E5-4655 v4 (Broadwell) that has CPUID 406F1, and according to /proc/cpuinfo is Family 6 Model 79 Stepping 1. This is 06-4f-01 in hex.

From Intel's latest "microcode revision guidance" PDF, they state that there are some microcode updates for 406F1 (although weirdly, my model isn't listen in the description, but we'll put that aside for now).

https://newsroom.intel.com/wp-content/uploads/sites/11/2018/03/microcode-update-guidance.pdf

Downloading the microcode update directly from intel, I do see a folder called 06-4f-01, which implies to me that something is there.

https://downloadcenter.intel.com/product/93808/Intel-Xeon-Processor-E5-4655-v4-30M-Cache-2-50-GHz-

However, in the release notes for the Ubuntu intel-microcode package, there is no mention of my CPUID. And in fact, I am not getting an update beyond 2017-03-01 (3.20180108.1), as indicated by the Ubuntu release notes.

http://changelogs.ubuntu.com/changelogs/pool/main/i/intel-microcode/intel-microcode_3.20180312.0~ubuntu16.04.1/changelog

Is there a reason why the Ubuntu package doesn't contain my CPUID, but the intel download does? Please note that I have not applied the code directly from intel yet, as I would rather stick to Ubuntu packages.

Thanks for your help

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu intel-microcode Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2018-04-11
Last query:
2018-04-11
Last reply:
2018-04-11

I suggest you report a bug

Manfred Hampl (m-hampl) said : #2

1. I recommend that you check the whole changelog of the Ubuntu packages
https://launchpad.net/ubuntu/+source/intel-microcode/+changelog

 There is a remark in the 3.20180108.1 release:
    + Downgraded microcodes:
      sig 0x000406f1, pf_mask 0xef, 2017-03-01, rev 0xb000021, size 26624
      sig 0x000506c9, pf_mask 0x03, 2017-03-25, rev 0x002c, size 16384
    + This removes IBRS/IBPB support for these two platforms when compared
      with the previous (and unofficial) release, 20171215. We don't know
      why Intel declined to include these microcode updates (as well as
      several others) in the release.

2. If you read the changelog inside the Intel tarball you also will not find any comment on 406F1 (or 06-4f-01).

JT (jonnytdevops) said : #3

Regarding 1), I did see that, but this is wrt an older intel release.

Regarding 2), thanks for pointing that out. I missed the changlog inside the tarball. However, a folder for 06-4f-01 does exist inside:

$ ls intel-ucode/06-4f-01
intel-ucode/06-4f-01

What is that for?

I guess if the Ubuntu package simply includes this tarball verbatim, then my question is moot.

JT (jonnytdevops) said : #4

And a better question: If intel are claiming that 0xB00002A is ready for 406F1 as per their PDF, where is it?

Manfred Hampl (m-hampl) said : #5

I suggest that you compare the contents of the intel tarball and the Ubuntu *.deb package, and you should see that the 06-47-01.* files in these are identical.

I do not know how to check the version number of such microcode file.

JT (jonnytdevops) said : #6

The files are actually different:

# find . -name 06-4f-01*
./intel-ucode/06-4f-01
./ubuntu_deb/lib/firmware/intel-ucode/06-4f-01.initramfs

./intel-ucode is the tarball from intel and ubuntu_dev is an extraction of intel-microcode_3.20180312.0~ubuntu16.04.1_amd64.deb

Strangly, the following link doesn't mention 06-4f-01 at all:
https://packages.ubuntu.com/xenial/amd64/intel-microcode/filelist

Best Manfred Hampl (m-hampl) said : #7

I compared the file from the Ubuntu 18.04 deb file and from the Intel tarball, and they are reported as identical (the name differs)
And you should not trust the packages.ubuntu.com reports too much.

If you see a problem, please create a bug report.

JT (jonnytdevops) said : #8

Yeah, I also notice that too :(

I wonder where 0xB00002A for 406F1 went.

JT (jonnytdevops) said : #9

Thanks Manfred Hampl, that solved my question.