When opening/importing pdf into inkscape it crashes

Asked by tobiwan on 2009-12-10

When I try to open a pdf file with inkscape or opening it from inkscape itself, inkscape crashes. When trying from terminal I get

$ inkscape Ausgabe.pdf
inkscape: symbol lookup error: inkscape: undefined symbol: _ZN12GlobalParamsC1Ev
$

the same happens, when I try to open a completely "emtpy" pdf

I am using inkscape 0.47 on Ubuntu 9.10

I recently had some problems with my inkscape, maybe its related...
https://answers.launchpad.net/ubuntu/+source/apt/+question/92139

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
Danilo Piazzalunga
Solved:
2009-12-15
Last query:
2009-12-15
Last reply:
2009-12-14

Have you installed Inkscape from the Ubuntu Software Center (or the Ubuntu repositories)? Are you still using the hacks described in question #92139?

tobiwan (tobias-opialla) said : #2

I did install it from the Software Center. And since after that I still had the problems described I asked the question #92139. And that way I am still using it...

Ubuntu 9.10 includes inkscape 0.47~pre4-0ubuntu1, which does NOT requre either libMagick++.so.1 or libpoppler.so.4. Please check which libraries Inkscape is using with the following command:

ldd /usr/bin/inkscape | egrep '(poppler|Magick)'

Your output should be something like this:

$ ldd /usr/bin/inkscape | egrep '(poppler|Magick)'
 libMagick++.so.2 => /usr/lib/libMagick++.so.2 (0x00e1c000)
 libMagickCore.so.2 => /usr/lib/libMagickCore.so.2 (0x0293b000)
 libpoppler.so.5 => /usr/lib/libpoppler.so.5 (0x0178f000)
 libpoppler-glib.so.4 => /usr/lib/libpoppler-glib.so.4 (0x00e8f000)
 libMagickWand.so.2 => /usr/lib/libMagickWand.so.2 (0x0152e000)

tobiwan (tobias-opialla) said : #4

It is:
~$ ldd /usr/bin/inkscape | egrep '(poppler|Magick)'
        libMagick++.so.2 => /usr/lib/libMagick++.so.2 (0x00d68000)
        libMagickCore.so.2 => /usr/lib/libMagickCore.so.2 (0x05ea0000)
        libpoppler.so.5 => /usr/lib/libpoppler.so.5 (0x01ed0000)
        libpoppler-glib.so.4 => /usr/lib/libpoppler-glib.so.4 (0x00e0f000)
        libMagickWand.so.2 => /usr/lib/libMagickWand.so.2 (0x06f7d000)
~$

seems rather similar to me... do you need other outputs?

btw: thanks for your help

Try removing the symbolic links you created in question #92139; you should solve this problem...

tobiwan (tobias-opialla) said : #6

How do I do that? and would inkscape not show the same faulty behaviour as before (creating the links)?

Inkscape should not even consider those links... This is a weird problem. Have you tried removing and reinstalling the inkscape package?

tobiwan (tobias-opialla) said : #8

i just did, via synaptic, and still can start inkscape, but when trying with a pdf I get:
$ inkscape Ausgabe2.pdf
inkscape: symbol lookup error: inkscape: undefined symbol: _ZN12GlobalParamsC1Ev
$

tobiwan (tobias-opialla) said : #9

I am just not certain which of the links to delete..., respectively which are the correct file names

You should delete

/usr/lib/libMagick++.so.1
/usr/lib/libMagickCore.so.1
/usr/lib/libpoppler.so.4

These old libraries should not exist on a Ubuntu 9.10 system and Inkscape does not depend on them.

tobiwan (tobias-opialla) said : #11

first: sorry for not coming here again for that long, but i am rather sick (but not swine flu)

well I did this, and now I again get

$ inkscape
inkscape: error while loading shared libraries: libMagick++.so.1: cannot open shared object file: No such file or directory
$

so, the old problem reappears...

tobiwan (tobias-opialla) said : #12

I think I found out something interesting: I just uninstalled inkscape and afterwards (when i should get something like: inkscape is currently not installed) i get still:

$ inkscape
inkscape: error while loading shared libraries: libMagick++.so.1: cannot open shared object file: No such file or directory
$

I believe you have an old inkscape installation somewhere else,
probably in your home.

Use this command to find the old inkscape binary:

which inkscape

tobiwan (tobias-opialla) said : #14

~$ which inkscape
/usr/local/bin/inkscape
~$ ls /usr/local/bin/
inkscape inkview
~$

obviously you are right!
should I delete these files?
or/and something else?

Deleting these should effectively solve your problem.

You will only leave some (harmless) clutter under /usr/local: you could probably delete /usr/local/share/inkscape and its contents.

tobiwan (tobias-opialla) said : #16

Thanks Danilo Piazzalunga, that solved my question.

tobiwan (tobias-opialla) said : #17

thanks! Its running now! I had forgotten about a developer version I had installed ages ago!