inkscape document properties crash

Asked by Gary Ferrao on 2011-02-24

Hello someone,
I am facing a problem with Inkscape's Document Properties (Ctrl-Shift-D). Everytime i use the shortcut or select the option from the File menu, an error message appears saying "internal error, inkscape will now close" and then the program crashes. This way, i cant change the size of the page or rulings, etc when i want to.
I tired re-installing it, but it doesnt work.
Does anyone know what's wrong?
(I'm using Kubuntu 10.0 and i installed Inkscape via the default System Settings -> Software Management).

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu inkscape Edit question
Assignee:
No assignee Edit question
Solved by:
actionparsnip
Solved:
2011-02-25
Last query:
2011-02-25
Last reply:
2011-02-25

Have you logged a bug?
Doesit happen for all users?

marcus aurelius (adbiz) said : #2

which version of inkscape are you using? ver 0.48 has known bugs.

http://inkscape.org/download/

0.48 is advised for production systems and is default in Maverick.....

marcus aurelius (adbiz) said : #4

inkscape made a statement in sept 2010 saying there were lots of bugs with 0.48 and they'd be coming out with 0.48.1 in early november.

0.48.1 is supposed to be available that fixes all sorts of bug, but there seems to be a hold-up in the person packaging and uploading it.

anyhoo, i'm using 0.47 and it does't exhibit that problem.

As actionparsnip suggests, have you tried logging on as a different user, and seeing if the problem occurs when you run Inkscape as a different user? This is useful diagnostically, as typically when a problem is specific to one user, it can be fixed by editing or deleting that user's per-user configuration data for the application.

Alex Valavanis (valavanisalex) said : #6

Hi All,

This is a known bug, which occurs in inkscape 0.48.0 on Kubuntu (LP: #658055). The bug is fixed in Inkscape 0.48.1, which is now available in Ubuntu Natty (due to be released in April).

The problem arises when you use the "Oxygen" icon set. You can work around the bug by either switching to "Clearlooks" or following one of the other hints in the bug report.

It might be worth looking at a stable release update for Ubuntu Maverick.

Gary Ferrao (garyf) said : #7

ya i'm using 0.48 so i guess it may be a bug after all.

@Alex Valavanis: thanks for the info.. but how do you change the iconset? from Windows Decorations or Desktop Themes?
                            even then whenever i change the windows decorations, the buttond and titlebar dont appear properly.

Gary Ferrao (garyf) said : #8

and ya, its affecting all users

If you were feeling brave you may install the natty deb but it may have later deps than are available in maverick and you will need to satisfy them manually (could get VERY messy).

Scratch that:

sudo add-apt-repository ppa:ferramroberto/maverick ; sudo apt-get update; sudo apt-get upgrade

Gives 0.48.1 for maverick properly :)

Gary Ferrao (garyf) said : #11

Thanks actionparsnip, that solved my question.

Gary Ferrao (garyf) said : #12

and thanks to all of you actionparsnip, marcus aurelius, Eliah Kagan, Alex Valavanis for your time.
:)