ubuntu does not load the image from swap after hibernation

Asked by stephen bond on 2018-11-03

after upgrading from 16.04 to 18.04 the upgrade messes up the boot process and hibernatation does not work. I hibernate by

systemctl hibernate

it asks for a password and it seemingly saves the image and shuts down. when I start the computer it does not load the saved image but opens a blank session losing the saved workspace. very inconvenient to start from scratch every time.

Question information

Language:
English Edit question
Status:
Open
For:
Ubuntu initramfs-tools Edit question
Assignee:
No assignee Edit question
Last query:
2018-11-03
Last reply:
2018-11-20
stephen bond (stephen-cbond) said : #1

if anybody can help with making hibernation work on ubuntu 18.04 pls let me know.

the bug report is incomplete and I have no idea how to complete it.

Glenn Washburn (crass) said : #2

I would suggest making sure that either the "resume" kernel parameter is set in your grub.cfg or /etc/initramfs-tools/conf.d/resume is set with "RESUME=/path/to/swap/device". If your hibernation partition is not loaded at boot that could also be why.

These should already be set if it was working before the upgrade. If these are properly set then, you'll need to debug the hibernation. One way to do the hibernation, but when you boot up again, add "break=mountroot debug" to the kernel command line by editing the grub entry in the boot loader. When you get to a shell run "blkid" and verify that the swap device is listed and that its type is "swsusp".

Can you help with this problem?

Provide an answer of your own, or ask stephen bond for more information if necessary.

To post a message you must log in.