Is Compcache working on Intrepid?

Asked by Sb on 2009-02-03

Hi there,

I'm installing Ubuntu on an old laptop with 128 MB of RAM. I'd like to use Compcache. It appears Intrepid includes an implementation of Compcache by default? I just need to change the value in /etc/initramfs-tools/initramfs.conf?

Thanks a lot!

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu initramfs-tools Edit question
Assignee:
No assignee Edit question
Solved by:
juancarlospaco
Solved:
2009-02-03
Last query:
2009-02-03
Last reply:
2009-02-03

juancarlospaco@ibex:~$ lsb_release --release --codename ; echo " " ; cat /etc/initramfs-tools/initramfs.conf | grep --ignore-case Compcache
Release: 8.10
Codename: intrepid

# COMPCACHE_SIZE: [ "x K" | "x M" | "x G" | "x %" ]
# An empty value - compcache isn't used, or added to the initramfs at all.
# You can optionally install the compcache package to configure this setting
# via debconf and have userspace scripts to load and unload compcache.
COMPCACHE_SIZE=""

:)

Sb (sb56637) said : #2

Thanks for the reply!

So if I set it to COMPCACHE_SIZE="50 %" and then run "update-initramfs -u", I just reboot and it starts working? And where is the "compcache" package for Ubuntu?

Note the " optionally ", you can make it like you say, you have Skills, make backup.

Sb (sb56637) said : #4

Well, I had already tried it, but it didn't really seem to make much of a difference. That's why I thought I had to install or configure something else. If anyone has more tips, please mention them here. Thanks for the fast reply.

Sb (sb56637) said : #5

Thanks juancarlospaco, that solved my question.