old kernel image keeps re-appearing and crashing initramfs update

Asked by larsno on 2008-03-10

I had an old kernel image (that I am not using) in /boot/, and when attempting to update initramfs-tools bug #98984 caused initramfs to fail. This in turn caused dpkg to fail... and this has caused Synaptic to fail as per bug #200043.

Now, i'm stuck in a catch-22- I cannot remove the oldkernel using synaptic or apt due to the aforementioned bugs, and I've tried re-installing initramfs-tools from source, only it keeps saying:

cannot find /lib/modules/oldkernelname
update-initramfs: failed for boot/initrd.img-oldkernelname

I've removed all instances of the old kernel from grub/menu.1st and from boot/ (including vmlinuz-oldkernelname). Only when I try to re-install initramfs-tools boot/initrd.img-oldkernelname REAPPEARS!

So, my question is: what do i need to remove so that initramfs will re-install? what is telling it to try to update triggers for this kernel that no longer exists?

Thanks in advance :)

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu initramfs-tools Edit question
Assignee:
No assignee Edit question
Solved by:
larsno
Solved:
2008-03-10
Last query:
2008-03-10
Last reply:
larsno (kostuk-gmail) said : #1

Well,

 I created the /lib/firmware/oldkernel and /lib/modules/oldkernel directories that it was looking for - even though they're empty!? - and I was able to recompile initramfs-tools from source !

So, problem has been worked-around... still not sure how to clean this up but I guess it's already in the Bug reports
Thanks for stopping by-