please help me unbork encrypted lvm boot process

Asked by Rolf Leggewie on 2011-04-30

My lucid system has an encrypted lvm to hold the partitions (/boot is on a separate partition, unencrypted). In a misguided attempt at clean-up I recently deinstalled the cryptsetup package. This led to an unusable initramfs the next time a kernel was installed and update-initramfs ran. At boot time, I get a message that /dev/mapper/1001p-root which holds the encrypted LVM does not exist and I am being dropped to a busybox shell.

By reinstalling cryptsetup and a few other things, I managed to fix the problem to the point that I can at least boot. But I need to enter the following commands in busybox to boot

cryptsetup luksOpen /dev/sda1 sda1_crypt
(enter password)
lvm vgchange -ay
exit

The boot then continues normally. I'm now trying to eliminate the need for those manual commands and get to booting as normal. How can I do that? I ran "sudo update-initramfs" a couple of times already but that didn't do it, yet. Your help is appreciated.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu initramfs-tools Edit question
Assignee:
No assignee Edit question
Solved by:
Rolf Leggewie
Solved:
2011-08-15
Last query:
2011-08-15
Last reply:
2011-05-15
Launchpad Janitor (janitor) said : #1

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

Rolf Leggewie (r0lf) said : #2

I'm not sure that I may have hit some kind of bug. My fstab mounted / via its UUID. As such, the scripts did not include the cryptroot script in the initramfs, but that's necessary for decryption of the LVM. Mounting / via /dev/mapper/$mapperID worked find and now "sudo update-initramfs" works again as it should.

Rolf Leggewie (r0lf) said : #3

#2 solved the issue at hand for me