Indicator-Weather not refreshing

Asked by Andrew K on 2012-07-31

For a little over a week now the indicator-weather has been displaying the exact same weather data and all you get from the dropdown is "Refreshing, please wait" yet there is absolutly no network activity from the process and it just sits there in this state without any notification of crash or failure. I have restarted the indicator, restarted the computer, un-installed and re-installed the indicator and it still does the same thing. It doesn't even seem to make any difference if I select yahoo or google as source. My screenlets "clear weather" is working just fine. I also tryed to install My-Weather indicator... even that displayed incorrect weather data so I removed it straight away. Is this a Google/Yahoo issue???

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu indicator-weather Edit question
Assignee:
No assignee Edit question
Solved by:
Andrew K
Solved:
2012-07-31
Last query:
2012-07-31
Last reply:
2012-07-31

Can you give the output of:

lsb_release -a; uname -a; dpkg -l | grep -i weather

Thanks

Andrew K (andyk1166) said : #2

lsb_release -a; uname -a; dpkg -l|grep -i weather as follows:

LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 12.04 LTS
Release: 12.04
Codename: precise
Linux andy-NETBOX 3.2.0-27-generic-pae #43-Ubuntu SMP Fri Jul 6 15:06:05 UTC 2012 i686 i686 i386 GNU/Linux
ii indicator-weather 11.11.28-0ubuntu1 indicator that displays weather information
ii libgweather-3-0 3.4.1-0ubuntu1 GWeather shared library
ii libgweather-common 3.4.1-0ubuntu1 GWeather common files
ii python-pywapi 0.2.2-1 Python wrapper around different weather APIs

Have you tried both google and yaho for source? Did you show the temperature? Have you removed the location and readd it?

Andrew K (andyk1166) said : #5

I have tried both google and yahoo... the problem persists on either one. I actually fully unistalled the app and reinstalled it as well re-entering my location to no avail. This is actually looking like it is the Bug #964365

sudo add-apt-repository ppa:atareao/atareao
sudo apt-get update
sudo apt-get install my-weather-indicator

Try that.

Andrew K (andyk1166) said : #7

I actually just uninstalled the weather-indicator and downloaded & installed the fix from BUG #964365 and all is now working as it should except for the known issue with sunrise/sunset times... this is ok for now... future updates will correct that I'm sure. I actually had my-weather-indicator installed on another of my pc's but even that is showing a temperature for my area that is about 20 deg F lower than the actual temp. ??? For now the fix I installed will do nicely, Thanks for all the help, I was certainly not the only one baffled by this one.

Thats cool, glad you got the gold