No Shutdown Option in 11.10 Session Menu?

Asked by Paul Hansknecht

I'm running Ubuntu 11.10, and I suddenly have no Shutdown or System Information options in the Session Menu in the upper corner of the screen. It shows only "Switch User Account...", "Online Accounts...", and "User Accounts...". I regularly apply all updates via the Update Manager, including some this (11/10) morning.

Is there something wrong with my system, or am I looking in the wrong place to do a shutdown, or ???


Question information

English Edit question
Ubuntu indicator-session Edit question
No assignee Edit question
Solved by:
Last query:
Last reply:
Revision history for this message
Best enubuntu (mr.tennents) said :
Revision history for this message
actionparsnip (andrew-woodhead666) said :

If you run:

sudo shutdown -h now

Does it turn off ok?

Revision history for this message
Sam_ (and-sam) said :

Please install compizconfig-settings-manager.
Open a terminal: ctrl+alt+t
sudo apt-get install compizconfig-settings-manager

When finished, run:

Look for unity-plugin an verify it's activated.

Revision history for this message
Paul Hansknecht (phans) said :

Thanks Enrico "eNry" Carafa, that solved my question.

Revision history for this message
Paul Hansknecht (phans) said :

Sorry for the error in my first report of this problem. I mistakenly thought the shutdown info was missing from the Session Menu. It was actually the entire System Menu (the little "gear" icon) that was missing.

The little "gear" icon seems to be just out of view off the right-hand edge. I discovered that if I pushed my cursor against the right-hand end of the top of the screen, the System Menu drop-down menu would indeed appear.

The problem seems to be with the video driver/display? However, when I maximize folders and programs I don't lose any of their frame or controls off the right-hand edge of the display. Only the top menu bar seems to be a little too wide for the screen.

Revision history for this message
Sam_ (and-sam) said :

It sure isn't expected behaviour that session-menu is off the edge.
Here sometimes after reboot the screen size isn't recognized, e.g. conky moves off the bottom edge and on laptop the whole session-menu.
Either logout-in helps or as a workaround, beside the default resolution I've added screen resolution to display output in ccsm, e.g. 1920x1080+0+0 and move it to first position.
There're several bugs reported.
Bug #861604
Bug #873600
Bug #880917