How to disable the guest session in Oneiric?

Asked by Rocko on 2011-09-05

How do I disable the guest session in Oneiric?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu indicator-session Edit question
Assignee:
No assignee Edit question
Last query:
Last reply:

By default it isn't enabled. You can disable any account with:

sudo passwd -dl foo

replace foo with the username you login as 'guest' with

Rocko (rockorequin) said : #2

Thanks, that's useful information, but doesn't quite solve my question, so I should be more specific:

Oneiric has a feature whereby it temporarily creates a guest session account for you. So if I go to the session indicator menu that shows my name, there is a "Guest Session" option, and choosing it logs you in with a random username like "guestIz278gf". This guest user has no home folder and only shows up in /etc/passwd until you log him out.

So how do I disable this Guess Session feature?

Rocko (rockorequin) said : #3

I think I've found it: there's a package called gdm-guest-session installed which seems to provide the functionality I described.

Not installed here, quite strange. I'd remove it and see how you go....

Rocko (rockorequin) said : #5

I upgraded from natty, so maybe it was installed there.

However, removing gdm-guest-session makes no difference whatsoever, even after a reboot. I can still use indicator-session to switch to a guest session. Perhaps it is built into the new indicator-session? There's a command 'guest-account' available in bash but I'm not sure which package it belongs to.

Sam_ (and-sam) said : #6

Depends which login manager gdm or lightdm, config files are in /etc/lightdm/* or /etc/gdm/*.
But anyhow there is a known bug (linked) when it's disabled in greeter it shouldn't display in indicator.
Regarding (not only) dev releases it's helpful to review bug reports.

Can you help with this problem?

Provide an answer of your own, or ask Rocko for more information if necessary.

To post a message you must log in.