Indicator applet appmenu not working in Ubuntu 11.04

Asked by Steven D. Shown on 2011-09-22

I installed the indicator applet appmenu in Ubuntu 11.04 to use in classic mode (I have a mac theme on it), and after I installed it everything worked perfectly. Now all of a sudden, the appmenu (global menu) will not load. I tried restarting the computer, etc, but nothing helps. The global menu works in Unity mode, but the custom one I installed to use in classic mode does not. What can I do to get this appmenu to work? It's causing me to not have any menu choices at all when using google chrome.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu indicator-appmenu Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-13
Last reply:
2011-10-15

Does it work as another user?

No it doesn't. In Unity mode it works, but the custom global menu I installed in classic gnome mode does not at any point. It used to but now no longer does. Also, I am the only user on that computer.

Make another user and try there

After you make a new user and test, please let us know the result--with that information, we should be able to help you fix the problem in your existing user account (if it works in the new account), or for your whole system (if it doesn't work in the new account).

Ok, I have created a separate user account, and surprisingly the indicator applet appmenu works like it's supposed to. But when I log into my main (administrator) account it does not work at all. Hopefully you will be able to help me get this system fixed for all accounts with this information. Thank you.

Launchpad Janitor (janitor) said : #6

This question was expired because it remained in the 'Open' state without activity for the last 15 days.

I have had to re-open this question. I did indeed create a separate user account and everything worked ok on it, but when I log into my main (administrator) account, the indicator applet appmenu in classic gnome mode does not work at all. Please help me promptly if you can please

There is no single administration account in Ubuntu. Users in the 'admin' group can all use sudo. You now know the issue is settings and not the apps themselves.

OK, let's try and figure out what it is about your user-specific configuration that is breaking indicator-appmenu.

Please post the output of this command, run in your main user account (which has the problem) and your other user account (which does not have the problem):

ps ax | egrep 'indicator|appmenu'

To run that command, open a Terminal window (Ctrl+Alt+T) paste it in, and press enter. To provide the output, select all the text in the Terminal (Edit > Select All), copy it to the clipboard, and paste it here.

Scott Wilson (scawn) said : #10

I am having the exact same problem. I created a new account and the appmenu worked fine. I logged back into my admin account and deleted the second account. At first the appmenu acted like it was going to work as it showed up correctly, but then it started responding slow and ultimately stopped responding all together. It's the only issue I am having with running a mac theme in classic mode on 11.04 Here is what I got from the output in terminal

**********:~$ ps ax | egrep 'indicator|appmenu'
 2496 ? Rl 9:44 /usr/lib/indicator-applet/indicator-applet-appmenu
 2522 ? Sl 0:00 /usr/lib/indicator-sound/indicator-sound-service
 2524 ? Sl 0:00 /usr/lib/indicator-messages/indicator-messages-service
 2531 ? Sl 0:00 /usr/lib/indicator-application/indicator-application-service
**********:~$

Scott Wilson (scawn) said : #11

Here is the information from the user who CAN use the indicator-applet-appmenu correctly:

**********:~$ ps ax | egrep 'indicator|appmenu'
 1504 ? Sl 0:00 /usr/lib/indicator-applet/indicator-applet
 1534 ? Sl 0:00 /usr/lib/indicator-sound/indicator-sound-service
 1535 ? Sl 0:00 /usr/lib/indicator-messages/indicator-messages-service
 1536 ? Sl 0:00 /usr/lib/indicator-application/indicator-application-service
 2663 ? Sl 0:00 /usr/lib/indicator-applet/indicator-applet-complete
 2700 ? Sl 0:01 /usr/lib/indicator-applet/indicator-applet-appmenu
 2707 ? Sl 0:00 /usr/lib/indicator-applet/indicator-applet
 2715 ? Sl 0:00 /usr/lib/indicator-sound/indicator-sound-service
 2717 ? Sl 0:00 /usr/lib/indicator-messages/indicator-messages-service
 2719 ? Sl 0:00 /usr/lib/indicator-application/indicator-application-service
 3111 pts/0 S+ 0:00 egrep --color=auto indicator|appmenu
**********:~$

Can you help with this problem?

Provide an answer of your own, or ask Steven D. Shown for more information if necessary.

To post a message you must log in.