indicator-applet is invisible (almost)

Asked by Max Bowsher on 2009-03-23

Binary package hint: indicator-applet

I wanted to see what this "Indicator Applet" was, so I went "Add to panel", "Indicator Applet", and clicked "Add". Nothing happened. I clicked "Add" a few more times. I had an inkling what might be happening, and looked into the panel's gconf settings - sure enough, I had 7 copies of indicator-applet on my panel, but I couldn't see any of them.

Later, I happened to look at my LCD from an odd angle, and the changed contrast let me notice some faint ridges on the panel which turned out to be my multitude of indicator applets.

The indicator applet should have some distinct visual presence of its own.

Consistency is good, and the indicator applet and the notification area applet share similar purposes, so I think the indicator applet should use the concept of a small but visible marker/handle as the notification area does.

Question information

English Edit question
Ubuntu indicator-applet Edit question
No assignee Edit question
Last query:
Last reply:

This question was originally filed as bug #347538.

Sebastien Bacher (seb128) said : #1

bug #339818 was the bug requestion the opposite

Max Bowsher (maxb) said : #2

I don't understand the rationale expressed in bug 339818. If you were to carry that to its logical conclusion, you'd have to remove the handle from the notification area too.

I recommend sticking with the well-established UI of having a small handle on notification/indication applets for Jaunty and worrying about how to reinvent the concept of a panel applet that hosts zero-or-more widgets on the behalf of applications for Karmic, preferably in concert with GNOME upstream so that notification and indication don't offer unnecessarily differing behaviour.

Ted - this is moot because the indicator-applet will be visible by default, right? If so, I would propose we close this as invalid.

Max Bowsher (maxb) said : #4


If the applet happens to show some visible content by default, that may well be grounds to de-prioritize the issue, but that does not make it not-a-bug.

However, I don't think it does show any visible content by default - only when an actual indication is happening?

Ted Gould (ted) said : #5

On Wed, 2009-03-25 at 22:29 +0000, Rick Spencer wrote:
> Ted - this is moot because the indicator-applet will be visible by
> default, right? If so, I would propose we close this as invalid.

It will be installed by default, but it's also possible for people to
delete it and add it. Heck, people could have several if they so
wanted :)

I think that it should be set to low priority though, as it won't effect
most users and doesn't have an easy fix.

John Wiersba (jrw32982) said : #6

OK, I give up. What's the workaround that makes thing visible? I can't see it to remove it. (I'm running Jaunty)

John Wiersba (jrw32982) said : #7

How does one get rid of this thing (the indicator applet) when it is not displaying anything? It's invisible.

Max Bowsher (maxb) said : #8

I think you have to resort to staring *really hard* at the panel to spot the 1-pixel wide faint grey line that is the empty indicator applet :-/

Bernhard (b.a.koenig) said : #9

John Wiersba, put a Window list applet on your dock (have some windows open) and move it around: you will see the point where it hits against the "invisible" indicator applet.

Another way would be to open pidgin and activate the "libnotify popups" plugin. In that case you will see a real icon as indicator.

John Wiersba (jrw32982) said : #10

I did stare at it for 10 or 20 minutes and try right-clicking to try to locate it with my mouse (so I could remove it). I could not find it, even though I could see its effects of preventing the window list from expanding. I ended up recreating my panel in a different panel and then removing the entire original panel. That was a pain and I don't want to have to do it again if I can avoid it. I'd also prefer to avoid enabling some application (pidgin) that I'm not using.

Or, are there instructions for manipulating the files in .gconf (or whatever) to remove it?

Bernhard (b.a.koenig) said : #11

John, read my comment above yours.

John Wiersba (jrw32982) said : #12

Bernhard, I *did* read your comment. I can move the window list applet around and I can see where it is hitting up against the indicator applet, but I still cannot find where to right-click on the indicator applet in order to remove it. Like I mentioned, I also don't want to open pidgin (which I don't use) and activate a plugin.

Vish (vish) said : #13

@John Wiersba :
Didnt notice this was a question now!
To remove> Start evolution , this will show the icon , now you can remove it from the panel [right-click on applet and remove]

Or in the System> Preferences >Startup applications -> Uncheck the Indicator Applet ,
you can also remove the indicator applet entry from there.

Vish (vish) said : #14

@John Wiersba :
Rather than from Startup applications, killing the applet from the system monitor will remove it. [killing the process will ask for a reload application , but just select "Dont reload" ]

Can you help with this problem?

Provide an answer of your own, or ask Max Bowsher for more information if necessary.

To post a message you must log in.