Need to install Java. Have tried almost 25 times. Tried all the suggestions.

Asked by Rick Miller on 2013-01-09

I've been trying to 'enable" Java for quite some time with no success. Tried all the "fixes" here and elsewhere. My god, why does this have to be so difficult? Ubuntu 10.04--Google Chrome

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu icedtea-web Edit question
Assignee:
No assignee Edit question
Solved by:
Rick Miller
Solved:
2013-02-22
Last query:
2013-02-22
Last reply:
2013-01-09
Warren Hill (warren-hill) said : #1

Take a look here
https://help.ubuntu.com/community/Java

Do you have java installed and if so which one? To find out open a terminal by pressing CTRL, ALT and T.
Enter the follow commands:

-----------------------------------------------------
sudo update-alternatives --config java
-----------------------------------------------------
I see this
-----------------------------------------------------------------------------------------------------------
There are 2 choices for the alternative java (providing /usr/bin/java).

  Selection Path Priority Status
------------------------------------------------------------
* 0 /usr/lib/jvm/java-6-openjdk-i386/jre/bin/java 1061 auto mode
  1 /usr/lib/jvm/java-6-openjdk-i386/jre/bin/java 1061 manual mode
  2 /usr/lib/jvm/java-7-openjdk-i386/jre/bin/java 1051 manual mode

Press enter to keep the current choice[*], or type selection number:
warren@dell:~$
-----------------------------------------------------------------------------------------------------------
What do you see? Copy and paste the results back here and we can advise further

Rick Miller (69rixter) said : #2

rick@rick-laptop:~$ sudo update-alternatives --config java
There is only one alternative in link group java: /usr/bin/gij-4.4
Nothing to configure.

Morning W. Hill:

   Is this what your asking for? I checked in the Synaptic package manager and there are quite a few Java 'packages" installed!? Those packages are a result of what "downloaded" from Java site.
Rick

Warren Hill (warren-hill) said : #3

It is an option to upgrade your computer to Ubuntu 12.04?

Its an old version of both Ubuntu and Java.

Rick Miller (69rixter) said : #4

Warren:

   Yes, there is. However, I did have it installed and switched back after a multitude of problems developed (see/read all previous posts which were generated while in 12.04) OK, is it possible to just upgrade the Java? Would it be helpful to you if I posted all the packages that were installed w/ Java
Thanx"
Rick

Warren Hill (warren-hill) said : #5

It may help.

Rick Miller (69rixter) said : #6

Thanx Warren:

   I think I've solved this problem. I read, about 3 months ago, that JAVA was hacked, severely as I understand, recently and this could be the reasons for the problems. OK, my solution, I just dumped the latest JAVA! Funny that Ubuntu doesn't support recent JAVA installs anyway. So, onto getting my O.S. upgraded and we'll see how things proceed from there.
Later:

RICK