icedtea version for openjdk-7

Asked by Alain SAURAT on 2012-08-23

I try tu use an old applet which ran fine under Lucid and Firefox hang on it under Precise.
So I look with synaptic and I can see that the openjre/jdk v6 are installed with icedtea-6-plugin.
I decide to upgrade to openjre/jdk 7 with icedtea-7-plugin, but firefox can't open the applet.

I decide to test this with Chrome, and chrome says "your icedtea plugin is obsolete"....

I have seen in the official site of Icedtea taht the regular version for jre7 is 2.2 and Ubuntu give the 1.2, is it normal ?

Thanks, Alain

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu icedtea-web Edit question
Assignee:
No assignee Edit question
Solved by:
Alain SAURAT
Solved:
2012-08-23
Last query:
2012-08-23
Last reply:
2012-08-23

Can you give the output of:

lsb_release -a; uname -a

Thanks

Alain SAURAT (maisondouf) said : #2

the output of your commands:
papounet@amd8papou:~$ lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 12.04.1 LTS
Release: 12.04
Codename: precise
papounet@amd8papou:~$ uname -a
Linux amd8papou 3.2.0-29-generic #46-Ubuntu SMP Fri Jul 27 17:03:23 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux
papounet@amd8papou:~$

To have a good config for firefox launching applet, I was obliged to unistall all openjre/jdk and install the jvm Oracle version 7 (7u6-0~webupd8~0).
In synaptic the icedtea-plugin version is always the package '1.2-2ubuntu1.1' for icedtea-6-plugin and icedtea-7-plugin.

I don't know how to retreave my actual version of icedtea...