Ubuntu

IBus-1.4.0 problem with UBUNTU 11.10

Asked by Satyapriyananda on 2011-11-03

When typing "a ", ("a" followed by space), we get " a" (space followed by "a"). This is a problem with some characters in most Indian Languages as also Korean, Chinese etc (as I understand from the internet). Any solution in sight? Any meaningful alternative to IBus or any solution like going to an earlier version of IBus? Please help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ibus Edit question
Assignee:
No assignee Edit question
Solved by:
Jacobsallan
Solved:
2011-11-29
Last query:
2011-11-29
Last reply:
2011-11-28
Jacobsallan (jacobsallan) said : #1

What keyboard layout were you using?

In the Ibus Preferences dialog, there is an Advanced tab. In this tab, there is a checkbox "Use system keyboard layout". Is it checked?

Pick one input method that is misbehaving. Which one is it? Carefully document one instance of misbehavior listing the keyboard characters you type.

Are you using a Windows PC keyboard ( http://en.wikipedia.org/wiki/Enhanced_keyboard#Keyboard_layouts ) or a close variant? That will help communications because we can use qwerty key labels to describe keystrokes.

It is a Compaq-Presario Laptop that I use. http://h10025.www1.hp.com/ewfrf/wc/product?cc=us&lc=en&dlc=en&product=3360308

In the Preference dialog box, under Advanced Tab, "Use system keyboard layout" is checked.

With reference to one of the languages sa-translit(M17n), I give the following strokes with comments:

aa should type as ā It is Ok
ii should type as ī It is Ok
uu should type as ū It is Ok

Rama<space> types as Rma a NOT ok

sa-translit(m17n) types as s-atrnaslti(m17n) NOT ok

Please help.

Jacobsallan (jacobsallan) said : #3

sa-translit is not one of the input methods I expected. This is not an Ubuntu package download. How did you upgrade ibus for this input method? I found some web references, but would like to duplicate what you did.

I got interested in UBUNTU from 10.04. Then I learnt about IBus. I went for the language support and found many languages including Sanskrit. But I wanted the transliteration and I searched the web for it. I think that is how I came across this web site:

http://thanhsiang.org/faqing/node/139 or some such web site.

There you will find the mim file and all the instruction that goes with it.

I do not think I added any mim file other than sa-itrans and I did a repeat of that so that the resulting character is an equivalent in another font (created with fontographer or fontmonger ASCII code 0 to 255) I was previously using. [You see, I started with DOS about 42 years ago moved to WINDOWS upto WINDOWS 7 and am now happy with UBUNTU.] I called that sa-DFont-itrans.mim on the same pattern. That also worked.

I chose this sa-itrans as the example because you will have no difficulty in following the characters. The problem exists in other Indian languages which are packaged with UBUNTU. Bengali, Tamil, Hindi all have this problem. I think these came packaged with UBUNTU and the language support it offers. These are complicated enough not to permit exploration by a novice. For example, k gives ক্ ka gives ক ki gives কি kai gives কৈ ko gives কো kau with কৌ . I have followed the keystrokes in English with an End Key or Arrow key or Alt key so that it behaves properly. kaa gives কা. The Alt key gets you out of the language selection!!

**************** As far as upgrading to IBus-1.4.0, I followed the procedure suggested in the following link: ************

https://answers.launchpad.net/ubuntu/+source/ibus/+question/175813

Of course there was a make problem and some fatal error which you will find if you visit the above link. But I had the same problem in keystrokes even with IBus-1.3.999 .... I thought upgrading might help. Any way previously there was no problem before going in for UBUNTU 11.10 upgrade.

In case you are not able to visit the link above, I give two outputs which may help. The first is for the upgrading and the second after running update manager.

************************ upgrading to IBus-1.4.0 ****************** suggested by actionparsnip

sudo add-apt-repository ppa:createsc/3beol; sudo apt-get update;
[sudo] password for satyapriyananda:
You are about to add the following PPA to your system:
 3beol
 3beol
 More info: https://launchpad.net/~createsc/+archive/3beol
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.h8Pf1jic5L --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 5FB774E9865AA4195639F54D591B856E37964957
gpg: requesting key 37964957 from hkp server keyserver.ubuntu.com
gpg: key 37964957: "Launchpad 3beol" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
Ign http://in.archive.ubuntu.com oneiric InRelease
Ign http://in.archive.ubuntu.com oneiric-updates InRelease
Ign http://in.archive.ubuntu.com oneiric-proposed InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
Ign http://security.ubuntu.com oneiric-security InRelease
Hit http://archive.canonical.com oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://in.archive.ubuntu.com oneiric Release.gpg
Hit http://in.archive.ubuntu.com oneiric-updates Release.gpg
Hit http://security.ubuntu.com oneiric-security Release.gpg
Hit http://archive.canonical.com oneiric Release
Hit http://in.archive.ubuntu.com oneiric-proposed Release.gpg
Hit http://ppa.launchpad.net oneiric Release
Hit http://security.ubuntu.com oneiric-security Release
Hit http://in.archive.ubuntu.com oneiric Release
Hit http://archive.canonical.com oneiric/partner i386 Packages
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://security.ubuntu.com oneiric-security/main Sources
Hit http://in.archive.ubuntu.com oneiric-updates Release
Ign http://archive.canonical.com oneiric/partner TranslationIndex
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted Sources
Hit http://security.ubuntu.com oneiric-security/universe Sources
Hit http://security.ubuntu.com oneiric-security/multiverse Sources
Hit http://security.ubuntu.com oneiric-security/main i386 Packages
Hit http://security.ubuntu.com oneiric-security/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed Release
Hit http://in.archive.ubuntu.com oneiric/main Sources
Hit http://in.archive.ubuntu.com oneiric/restricted Sources
Hit http://in.archive.ubuntu.com oneiric/universe Sources
Hit http://in.archive.ubuntu.com oneiric/multiverse Sources
Hit http://in.archive.ubuntu.com oneiric/main i386 Packages
Hit http://security.ubuntu.com oneiric-security/universe i386 Packages
Hit http://security.ubuntu.com oneiric-security/multiverse i386 Packages
Hit http://security.ubuntu.com oneiric-security/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/multiverse TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/main Sources
Hit http://in.archive.ubuntu.com oneiric-updates/restricted Sources
Hit http://in.archive.ubuntu.com oneiric-updates/universe Sources
Hit http://security.ubuntu.com oneiric-security/main Translation-en
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse Sources
Hit http://in.archive.ubuntu.com oneiric-updates/main i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/main TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/main i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/main TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Hit http://security.ubuntu.com oneiric-security/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/main Translation-en
Hit http://in.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/main Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/main Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/universe Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_IN
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://archive.canonical.com oneiric/partner Translation-en_IN
Ign http://archive.canonical.com oneiric/partner Translation-en
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release [1,347 B]
Get:3 http://dl.google.com stable/main i386 Packages [1,233 B]
Ign http://dl.google.com stable/main TranslationIndex
Ign http://dl.google.com stable/main Translation-en_IN
Ign http://dl.google.com stable/main Translation-en
Fetched 2,778 B in 2min 26s (18 B/s)
Reading package lists... Done

Here is further output (because I re-ran it says below that ibus is the
newest version; I checked it to be ibus-1.4.0 in About):

sudo apt-get install ibus; sudo ppa-purge ppa:createsc/3beol
Reading package lists... Done
Building dependency tree
Reading state information... Done
ibus is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up crossplatformui (1.0.27) ...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service acpid restart

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) and then start(8) utilities,
e.g. stop acpid ; start acpid. The restart(8) utility is also available.
acpid stop/waiting
acpid start/running, process 5215
package libqtgui4 exist
QT_VERSION = 4
make -C /lib/modules/3.0.0-13-generic/build M=/usr/local/bin/ztemtApp/zteusbserial/below2.6.27 modules
make[1]: Entering directory `/usr/src/linux-headers-3.0.0-13-generic'
 CC [M] /usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o
/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.c:34:28: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
make[2]: *** [/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o] Error 1
make[1]: *** [_module_/usr/local/bin/ztemtApp/zteusbserial/below2.6.27] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-13-generic'
make: *** [modules] Error 2
dpkg: error processing crossplatformui (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                             Errors were encountered while processing:
 crossplatformui
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo: ppa-purge: command not found

The error with crossplatformui occurs every time as it is a third party
software or some such reason. But there seem to be some make problems
and fatal errors.

It solved the problem in so far as installing ibus-1.4.0 as indicated in
About?

I cannot set preferences for languages. The only things that I can
access are: About, Restart. (Quit I did not try even). Ctrl+space gave
ISPELL and I could not go further to select the languages. Rebooting did
not help.

I tried ibus-setup It showed the last line as error with IndexError: pop
from empty list: Output of ibus-setup is given below.

Traceback (most recent call last):
 File "/usr/share/ibus/setup/main.py", line 479, in <module>
   setup = Setup()
 File "/usr/share/ibus/setup/main.py", line 76, in __init__
   self.__init_ui()
 File "/usr/share/ibus/setup/main.py", line 215, in __init_ui
   self.__engines = self.__bus.list_engines()
 File "/usr/lib/python2.7/dist-packages/ibus/bus.py", line 139, in list_engines
   return map(serializable.deserialize_object, engines)
 File "/usr/lib/python2.7/dist-packages/ibus/serializable.py", line 54, in deserialize_object
   o.deserialize (struct)
 File "/usr/lib/python2.7/dist-packages/ibus/enginedesc.py", line 119, in deserialize
   self.__symbol = struct.pop(0)
IndexError: pop from empty list

Thanks for the help so far. Kindly suggest how to go further from here.
Thanks once again.

********************* Update Manager **************************

After the previous feedback, I ran update manager which said that it
will do ONLY a partial upgrade. I said ok. Thereafter I found that I get
the languages etc as before. Many many thanks for your help.

However, there may be some problem which everyone seems to be facing. It
is this: when you type "a ", (that is "a" followed by space), it becomes
" a". (space followed by a). Is there any fix for it? I found the
problem to be this: Raamak.r.s.na key sequence gives Rāmkaṛṣṇ a. Only
when the key sequence in which there is a key conversion for the double
sequence such as "aa" or "ii" or "uu" for getting ā ī ū, a "a " or "i "
or "u " gives " a", " i" or " u". It may be quite easy to modify the mem
(i have not done this for a long while!) table suitably. The problem
does not exist for "s ", "p " or any such thing where there is no double
key sequence like ss or pp. This may help the developers of ibus.

And in case the make errors and the fatal error are important, please
tell me what I should do. AS of now I can still go ahead temporarily by
repeatedly using ctrl+space to get into and out of ibus. Or, change the
mem table.

In the previous version which worked with UBUNTU 11.04, we could get the
language list by just clicking the icon; there was no need to use
Ctrl+space.

I use an MTS data card (wireless broadband connection; that is where I
think the crossplatformui comes in) on USB when I do not get the
broadband wired connection, and that is a rare feature.

Thanks once again. the repository information will help many who use
ibus.

******************* here it ends ****************

I am new to this. But this I find as useful. Whenever I want to type just a, i, or u, I should follow it with a useless keystroke like arrow key or End key. Then the thing can be managed. But it is cumbersome and fast typing cannot be done this way. I am sorry for a long additional information.

Hi,

Even with the default telugu-rts transliteration shipped with ibus-m17n package, I encounter this problem. It is very problematic.

Here is further information about my system configuration:

Ubuntu: 11.10
IBus: 1.3.99.20110818

Is there any work-around?

I'm not sure if this further information could be any help to solve this problem. When I tried "A<space>", it works well, but "a<space>" add a space before the associated consonant. For example,

"ammA " gives "అమ్మా ", where as "amma " gives "అ మ్మ".

In the later case, the space gets before the consonant+vowel pair. I've checked if it is some mapping problem in te-rts.mim and te-itrans.mim. But it doesn't look like.

Jacobsallan (jacobsallan) said : #7

Just to make sure, there is an Ibus bug with synopsis ibus-table only works with us keyboard layout.

http://code.google.com/p/ibus/issues/detail?id=830&colspec=ID%20Component%20Type%20Status%20Priority%20Stars%20Milestone%20Owner%20Summary&start=100

There are some 400 Ibus bugs posted. Only a few are for an Indic language. Issue #1334 looks promising.

Issue #1164 ibus-table not showing all phrase matching with key in candidate windows
Issue #1165 cant add new phrase in ibus-table
Issue #1213 Bugs in Telugu Apple KeyMapping
Issue #1258 0x0972 character code in Devnagari
Issue #1334 I-bus space is being placed in wrong location

If #1334 is appropriate, add to it starting at http://code.google.com/p/ibus/ . Your opinions?

The problem is not only with I-bus space being placed in the wrong location.

To me it seems to be a reversal from left-to-right to right-to-left following some keys like a, i, u, temporarily for just one keystroke. There could be other key-combinations also as given below.

Not that "a<space>" becomes "<space>a" alone but that "a-" becomes "-a", "an" becomses "na", and "li" becomes "il" in typing sa-translit: s-atrnaslti .

Ramakrishna types as follows: Rmakarsihn a (am, is and a<space> get affected to ma, si, <space>a).

Now, why a, i and u? These keys are there in the mapping as "aa", "ii" and "uu". If instead we use only "A', "I", and "U", this problem may be avoided? But Tamil, Telugu, Bengali ..... I do not know.

In Tamil for example, "ko" is written as கொ "k" is க் and the "o" in "ko" appears with that which precedes and succeeds கொ, there being a place holder for "k" க. So "to" becomes தொ. In all these places also, there is this reversal of "ko<space>" to "<space>ko", ko being treated as a unit. "to<space>" becomes "<space>to", and so on. That becomes complicated. We have to consider a, e, i, o, u (all vowels).

Perhaps ";a" instead of "aa", and so on will help. Will "k;o" serve the purpose of "ko" under this revised mapping with "k;o<space>" remaining as "k;o<space>"? It has to be figured out. I do not know if all this helps. I am happy people are at it.

I have checked this out: pressing a useless key such as arrow or End after the vowels helps solve the problem; it is tedious though. In Sanskrit we can have a combination like hantrI or hantrii. where ha is one character and ntrii or ntrI is another. This second character combines n, t, r, ii (or I) and hence it is not clear to the logic where the combination ends, after two characters or three characters or even four characters in English. So, all these characters are kept in one bracket indicated by an underscore. A vowel followed by any key other than a vowel ends the combination may be a good logic.

As it is, two vowels seem to end the combination. Try combinations "ka" like; and "kai" or "kii" like.

And vowel followed by non-vowels get reversed where those vowels are in the mapping. If "o" is not in the mapping, "op" types "op" but "ap" becomes "pa", because "a" is in the mapping.

Jacobsallan (jacobsallan) said : #9

There are not enough bug reports at http://code.google.com/p/ibus/ .

I have submitted the bug on http://code.google.com/p/ibus/ ( http://goo.gl/Ljrjs ).

Did anyone find how it can be solved?

20 November 2011

Dear Sir/Madam,

Please read my opinion. Nobody seems to be bothering about these problems:

The problem is not only with I-bus space being placed in the wrong location.

To me it seems to be a reversal from left-to-right to right-to-left
following some keys like a, i, u, temporarily for just one keystroke. There
could be other key-combinations also as given below.

Not that "a<space>" becomes "<space>a" alone but that "a-" becomes "-a",
"an" becomses "na", and "li" becomes "il" in typing sa-translit:
s-atrnaslti .

Ramakrishna types as follows: Rmakarsihn a (am, is and a<space> get
affected to ma, si, <space>a).

Now, why a, i and u? These keys are there in the mapping as "aa", "ii" and
"uu". If instead we use only "A', "I", and "U", this problem may be
avoided? But Tamil, Telugu, Bengali ..... I do not know.

In Tamil for example, "ko" is written as கொ "k" is க் and the "o" in "ko"
appears with that which precedes and succeeds கொ, there being a place
holder for "k" க. So "to" becomes தொ. In all these places also, there is
this reversal of "ko<space>" to "<space>ko", ko being treated as a unit.
"to<space>" becomes "<space>to", and so on. That becomes complicated. We
have to consider a, e, i, o, u (all vowels).

Perhaps ";a" instead of "aa", and so on will help. Will "k;o" serve the
purpose of "ko" under this revised mapping with "k;o<space>" remaining as
"k;o<space>"? It has to be figured out. I do not know if all this helps. I
am happy people are at it.

I have checked this out: pressing a useless key such as arrow or End after
the vowels helps solve the problem; it is tedious though. In Sanskrit we
can have a combination like hantrI or hantrii. where ha is one character
and ntrii or ntrI is another. This second character combines n, t, r, ii
(or I) and hence it is not clear to the logic where the combination ends,
after two characters or three characters or even four characters in
English. So, all these characters are kept in one bracket indicated by an
underscore. A vowel followed by any key other than a vowel ends the
combination may be a good logic.

As it is, two vowels seem to end the combination. Try combinations "ka"
like; and "kai" or "kii" like.

And vowel followed by non-vowels get reversed where those vowels are in the
mapping. If "o" is not in the mapping, "op" types "op" but "ap" becomes
"pa", because "a" is in the mapping.

I hope you agree to what I say.

Yours sincerely,

Satyapriyananda

2011/11/19 కోడూరి గోపాలకృష్ణ <email address hidden>

> Your question #177355 on ibus in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/ibus/+question/177355
>
> కోడూరి గోపాలకృష్ణ posted a new comment:
> I have submitted the bug on http://code.google.com/p/ibus/ (
> http://goo.gl/Ljrjs ).
>
> Did anyone find how it can be solved?
>
> --
> You received this question notification because you asked the question.
>

--
Vanity of all vanities; all is vanity except taking the Name of God and
singing His Glories.

Swami Satyapriyananda
Ramakrishna Mission
    Swami Vivekananda's
    Ancestral House and Cultural Centre
3 Gour Mohan Mukherjee Street
Kolkata 700006
INDIA

Mobile No: +91 91432 44935

Dominik Wujastyk (wujastyk) said : #12

I confirm having exactly the same problems as so carefully documented by Satyapriyananda. It's making typing Indic languages almost impossible. This problem started with me at around the same time as I installed Ubuntu 11.10, though I can't be absolutely sure that's the trigger. I run ibus/m17n on three different machines, and they all show the same wrong behaviour.

Dominik Wujastyk
University of Vienna.

(Hello, Kolkata!)

Dominik Wujastyk (wujastyk) said : #13

See the bug report here:

https://bugs.launchpad.net/ubuntu/+source/ibus-hangul/+bug/840823

I suggest that this present thread is ended, and the discussion moved over to bug 840823, which seems to be getting fuller discussion and action.

Best,
Dominik

Kindly read #11 above. Also read the comment #12 in support. The problem is not with space only as made out in bug 840823.

So, kindly see that this thread gets its importance.

Best Jacobsallan (jacobsallan) said : #15

Ticket 840823 is a duplicate of ticket 880876. 880876 refers to Ibus issue 1291. That issue says that the problem may be due to Unity setting IBUS_ENABLE_SYNC_MODE to 1.

There is quite a bit of traffic about IBUS_ENABLE_SYNC_MODE and it's side effects. The problems are not limited to Indic languages or Korean. Try Googling for IBUS_ENABLE_SYNC_MODE to see these references.

If this really is the root cause, using a different window manager will help (like Gnome classic).

I think the best solution so far is to switch to Gnome classic. Steps:
sudo apt-get install gnome-shell
And this may be followed by upgrade and update and install.
In the log-on screen, choose the gear symbol and select gnome classic (without effects) and I think you will be problem free.
This, until a better solution is available.

Incidentally env does not show IBUS_ENABLE_SYNC_MODE as an environmental parameter.

Dominik Wujastyk (wujastyk) said : #17

A change to Gnome has the same effect. Ibus and m17n work fine.

Follow the same gnome-shell installation described above, and chose "Gnome" at login. Gnome is quite classy; I'm liking it, though once again there's a bit of a learning curve (greatly helped by the various tips at http://www.webupd8.org). Gnome Classic is a familiar old friend. Both are good.

At some point, Unity will be fixed, and we can move back if we wish. Meanwhile, at least we can now work again.