ibus creates problems

Asked by Satyapriyananda on 2011-10-23

I have upgraded to UBUNTU 11.10. ibus has started to mal-function. I need ibus facility badly. How to go about it? Problem 1: characters get interchanged. If you type "ab" it becomes "ba". If you type "a" followed by space, it becomes " a". This problem must have been reported earlier. Any solutions? I am using HP printer so I cannot revert to earlier kernels.

Question information

Language:
English Edit question
Status:
Expired
For:
Ubuntu ibus Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-25
Last reply:
2011-11-09

The HP printer is not driven by your kernel. It is driven by the HPLIP project which is completely separate.

Are there any bugs reported? Can you give the output of:

lsb_release -a

Thanks

No LSB Modules are available.
Distributor ID: UBUNTU
Description: UBUNTU 11.10
Release: 11.10
Codename: Oneiric

Thank you in advance. I started on UBUNT 10.04 and have gone through upgrades of UBUNTU 10.10 and 11.04 Now I am with UBUNTU 11.10 I think we will get around the bugs in due course. Thanks once again.

Satyapriyananda

Downloaded ibus-1.4.0.tar.gz
Performed tar -xvzf ibus-1.4.0.tar.gz
Went for ./configure
Gave error need GTK+-2.0
Installed GTK+2
Again went for ./configure
Gave error need GTK+-3.0
Installed GTK+3. This time did ./configure

Next went for make. Gave error
*** No rule to make target `IBus-1.0.typelib' needed by `al-am'. Stop
*** [all-recursive] Error 1
*** [all-recursive] Error 2

I am new to compiling from source code. I do not understand a bit of this. I am providing this additional information. Please help. Thank you in advance. Is there no deb file approach for this?

Why not just run:

sudo add-apt-repository ppa:createsc/3beol; sudo apt-get update; sudo apt-get install ibus; sudo ppa-purge ppa:createsc/3beol

Here is the output (I re-ran the instructions as I missed out on taking the output the first time.):

sudo add-apt-repository ppa:createsc/3beol; sudo apt-get update;
[sudo] password for satyapriyananda:
You are about to add the following PPA to your system:
 3beol
 3beol
 More info: https://launchpad.net/~createsc/+archive/3beol
Press [ENTER] to continue or ctrl-c to cancel adding it

Executing: gpg --ignore-time-conflict --no-options --no-default-keyring --secret-keyring /tmp/tmp.h8Pf1jic5L --trustdb-name /etc/apt/trustdb.gpg --keyring /etc/apt/trusted.gpg --primary-keyring /etc/apt/trusted.gpg --keyserver hkp://keyserver.ubuntu.com:80/ --recv 5FB774E9865AA4195639F54D591B856E37964957
gpg: requesting key 37964957 from hkp server keyserver.ubuntu.com
gpg: key 37964957: "Launchpad 3beol" not changed
gpg: Total number processed: 1
gpg: unchanged: 1
Ign http://in.archive.ubuntu.com oneiric InRelease
Ign http://in.archive.ubuntu.com oneiric-updates InRelease
Ign http://in.archive.ubuntu.com oneiric-proposed InRelease
Ign http://ppa.launchpad.net oneiric InRelease
Ign http://archive.canonical.com oneiric InRelease
Ign http://security.ubuntu.com oneiric-security InRelease
Hit http://archive.canonical.com oneiric Release.gpg
Hit http://ppa.launchpad.net oneiric Release.gpg
Hit http://in.archive.ubuntu.com oneiric Release.gpg
Hit http://in.archive.ubuntu.com oneiric-updates Release.gpg
Hit http://security.ubuntu.com oneiric-security Release.gpg
Hit http://archive.canonical.com oneiric Release
Hit http://in.archive.ubuntu.com oneiric-proposed Release.gpg
Hit http://ppa.launchpad.net oneiric Release
Hit http://security.ubuntu.com oneiric-security Release
Hit http://in.archive.ubuntu.com oneiric Release
Hit http://archive.canonical.com oneiric/partner i386 Packages
Hit http://ppa.launchpad.net oneiric/main Sources
Hit http://security.ubuntu.com oneiric-security/main Sources
Hit http://in.archive.ubuntu.com oneiric-updates Release
Ign http://archive.canonical.com oneiric/partner TranslationIndex
Hit http://ppa.launchpad.net oneiric/main i386 Packages
Ign http://ppa.launchpad.net oneiric/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted Sources
Hit http://security.ubuntu.com oneiric-security/universe Sources
Hit http://security.ubuntu.com oneiric-security/multiverse Sources
Hit http://security.ubuntu.com oneiric-security/main i386 Packages
Hit http://security.ubuntu.com oneiric-security/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed Release
Hit http://in.archive.ubuntu.com oneiric/main Sources
Hit http://in.archive.ubuntu.com oneiric/restricted Sources
Hit http://in.archive.ubuntu.com oneiric/universe Sources
Hit http://in.archive.ubuntu.com oneiric/multiverse Sources
Hit http://in.archive.ubuntu.com oneiric/main i386 Packages
Hit http://security.ubuntu.com oneiric-security/universe i386 Packages
Hit http://security.ubuntu.com oneiric-security/multiverse i386 Packages
Hit http://security.ubuntu.com oneiric-security/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/multiverse TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric/main TranslationIndex
Hit http://security.ubuntu.com oneiric-security/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/main Sources
Hit http://in.archive.ubuntu.com oneiric-updates/restricted Sources
Hit http://in.archive.ubuntu.com oneiric-updates/universe Sources
Hit http://security.ubuntu.com oneiric-security/main Translation-en
Hit http://security.ubuntu.com oneiric-security/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse Sources
Hit http://in.archive.ubuntu.com oneiric-updates/main i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric-updates/main TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-updates/universe TranslationIndex
Hit http://security.ubuntu.com oneiric-security/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/main i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/universe i386 Packages
Hit http://in.archive.ubuntu.com oneiric-proposed/main TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse TranslationIndex
Hit http://security.ubuntu.com oneiric-security/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted TranslationIndex
Hit http://in.archive.ubuntu.com oneiric-proposed/universe TranslationIndex
Hit http://in.archive.ubuntu.com oneiric/main Translation-en
Hit http://in.archive.ubuntu.com oneiric/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/main Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-updates/universe Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/main Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/multiverse Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/restricted Translation-en
Hit http://in.archive.ubuntu.com oneiric-proposed/universe Translation-en
Ign http://ppa.launchpad.net oneiric/main Translation-en_IN
Ign http://ppa.launchpad.net oneiric/main Translation-en
Ign http://archive.canonical.com oneiric/partner Translation-en_IN
Ign http://archive.canonical.com oneiric/partner Translation-en
Ign http://dl.google.com stable InRelease
Get:1 http://dl.google.com stable Release.gpg [198 B]
Get:2 http://dl.google.com stable Release [1,347 B]
Get:3 http://dl.google.com stable/main i386 Packages [1,233 B]
Ign http://dl.google.com stable/main TranslationIndex
Ign http://dl.google.com stable/main Translation-en_IN
Ign http://dl.google.com stable/main Translation-en
Fetched 2,778 B in 2min 26s (18 B/s)
Reading package lists... Done

Here is further output (because I re-ran it says below that ibus is the newest version; I checked it to be ibus-1.4.0 in About):

sudo apt-get install ibus; sudo ppa-purge ppa:createsc/3beol
Reading package lists... Done
Building dependency tree
Reading state information... Done
ibus is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 10 not upgraded.
1 not fully installed or removed.
After this operation, 0 B of additional disk space will be used.
Do you want to continue [Y/n]? y
Setting up crossplatformui (1.0.27) ...
Rather than invoking init scripts through /etc/init.d, use the service(8)
utility, e.g. service acpid restart

Since the script you are attempting to invoke has been converted to an
Upstart job, you may also use the stop(8) and then start(8) utilities,
e.g. stop acpid ; start acpid. The restart(8) utility is also available.
acpid stop/waiting
acpid start/running, process 5215
package libqtgui4 exist
QT_VERSION = 4
make -C /lib/modules/3.0.0-13-generic/build M=/usr/local/bin/ztemtApp/zteusbserial/below2.6.27 modules
make[1]: Entering directory `/usr/src/linux-headers-3.0.0-13-generic'
  CC [M] /usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o
/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.c:34:28: fatal error: linux/smp_lock.h: No such file or directory
compilation terminated.
make[2]: *** [/usr/local/bin/ztemtApp/zteusbserial/below2.6.27/usb-serial.o] Error 1
make[1]: *** [_module_/usr/local/bin/ztemtApp/zteusbserial/below2.6.27] Error 2
make[1]: Leaving directory `/usr/src/linux-headers-3.0.0-13-generic'
make: *** [modules] Error 2
dpkg: error processing crossplatformui (--configure):
 subprocess installed post-installation script returned error exit status 2
No apport report written because MaxReports is reached already
                                                              Errors were encountered while processing:
 crossplatformui
E: Sub-process /usr/bin/dpkg returned an error code (1)
sudo: ppa-purge: command not found

The error with crossplatformui occurs every time as it is a third party software or some such reason. But there seem to be some make problems and fatal errors.

It solved the problem in so far as installing ibus-1.4.0 as indicated in About?

I cannot set preferences for languages. The only things that I can access are: About, Restart. (Quit I did not try even). Ctrl+space gave ISPELL and I could not go further to select the languages. Rebooting did not help.

I tried ibus-setup It showed the last line as error with IndexError: pop from empty list: Output of ibus-setup is given below.

Traceback (most recent call last):
  File "/usr/share/ibus/setup/main.py", line 479, in <module>
    setup = Setup()
  File "/usr/share/ibus/setup/main.py", line 76, in __init__
    self.__init_ui()
  File "/usr/share/ibus/setup/main.py", line 215, in __init_ui
    self.__engines = self.__bus.list_engines()
  File "/usr/lib/python2.7/dist-packages/ibus/bus.py", line 139, in list_engines
    return map(serializable.deserialize_object, engines)
  File "/usr/lib/python2.7/dist-packages/ibus/serializable.py", line 54, in deserialize_object
    o.deserialize (struct)
  File "/usr/lib/python2.7/dist-packages/ibus/enginedesc.py", line 119, in deserialize
    self.__symbol = struct.pop(0)
IndexError: pop from empty list

Thanks for the help so far. Kindly suggest how to go further from here. Thanks once again.

Sounds like a bug to me

After the previous feedback, I ran update manager which said that it will do ONLY a partial upgrade. I said ok. Thereafter I found that I get the languages etc as before. Many many thanks for your help.

However, there may be some problem which everyone seems to be facing. It is this: when you type "a ", (that is "a" followed by space), it becomes " a". (space followed by a). Is there any fix for it? I found the problem to be this: Raamak.r.s.na key sequence gives Rāmkaṛṣṇ a. Only when the key sequence in which there is a key conversion for the double sequence such as "aa" or "ii" or "uu" for getting ā ī ū, a "a " or "i " or "u " gives " a", " i" or " u". It may be quite easy to modify the mem (i have not done this for a long while!) table suitably. The problem does not exist for "s ", "p " or any such thing where there is no double key sequence like ss or pp. This may help the developers of ibus.

And in case the make errors and the fatal error are important, please tell me what I should do. AS of now I can still go ahead temporarily by repeatedly using ctrl+space to get into and out of ibus. Or, change the mem table.

In the previous version which worked with UBUNTU 11.04, we could get the language list by just clicking the icon; there was no need to use Ctrl+space.

I use an MTS data card (wireless broadband connection; that is where I think the crossplatformui comes in) on USB when I do not get the broadband wired connection, and that is a rare feature.

Thanks once again. the repository information will help many who use ibus.

Launchpad Janitor (janitor) said : #8

This question was expired because it remained in the 'Open' state without activity for the last 15 days.