ibus for Japanese input has stopped working

Asked by Stevos May on 2011-09-20

Well, as I said in the summary, ibus for Japanese input has suddenly stopped working. Using Ubuntu 10.04.

One minute it worked, and now it doesn't.

I have rebooted and checked all the preferences and language supports options many times and it all seems to be OK.
When I click on the keyboard icon in the top right of the screen I get my options of Japanese - anthy (m17n) and English - ispell (m17n) but when I click on either option, noting happens. Previously it would flash up with the selected option in a box on the bottom right of the screen and then I could type in Japanese.

Open to suggestions please.

It could be related - bizarrely my computer forgot all my passwords too just recently. Also, a red stop sign appeared in the top right corner of the screen alerting me to a computer problem - I have since forgotten what this was.

Thanks

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ibus Edit question
Assignee:
No assignee Edit question
Solved by:
Stevos May
Solved:
2011-10-03
Last query:
2011-10-03
Last reply:
2011-09-23

Stevos,

It's sounds like the error (that is what the stop-sign was) may well have been the reason. I suggest you run an update on your computer, makes sure it's completely up to date. Once you have done that un-install the japanese input app and then reinstall it and see if it works.
If it still doesn't work then log a bug report by opening a terminal and type in:
ubuntu-bug ibus

Also, you may like to consider upgrading to 11.04 or 11.10.

Stevos May (stevosmay) said : #2

I reinstalled ubuntu 10.04 from scratch and now everything works. Not sure my old computer would be up to the new version and, while it is still in beta stage, it might not work so well. I'll stick to what I know for the time being and hope ibus doesn't go wrong again.

Thanks for your reply.

Stevos May (stevosmay) said : #3

P.S. Nothing else worked when trying to solve the problem. Was a time consuming fix, but all is OK so I am happy now