I would like to type eszett ß and umlauts äüö on Ubuntu 11.04

Asked by Gabriel Pannwitz on 2011-05-09

How do I do that ?

Hardware: Dell Studio XPS, Typematrix 2030 USB keyboard ( configured as such in Gnome ) with the Dvorak layout.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ibus Edit question
Assignee:
No assignee Edit question
Solved by:
Gabriel Pannwitz
Solved:
2011-06-04
Last query:
2011-06-04
Last reply:
2011-05-09

You can either switch keyboard layouts (so you're using the keyboard layout of the language you're composing in), or, if you want to keep an English keyboard layout, see http://ubuntuforums.org/showthread.php?t=74638.

Gabriel Pannwitz (gabkdlly) said : #2

Well, right_alt + shift + " and then a o or u used to get me umlauts in previous versions of Ubuntu, but they do not any more.

I have yet to encounter a method of entering an eszett with my current layout that works.

Thomas Krüger (thkrueger) said : #3

Unluckily you did not tell us wich Dvorak layout you are using, there are several.
If you are usin "US Dvorak" you should switch to "US Dvorak international" which is pretty much the same, but has international characters (like ß and the umlauts) on most keys when AltGr is pressed. You can see a representation of the layout in the keyboard settings.

Gabriel Pannwitz (gabkdlly) said : #4

It does seem like switching layouts is the best that Ubuntu has to offer at the moment.

Thanks Thomas and Eliah for your help !!