the configure script on Ibus 1.5.0 won't produce a makefile

Asked by Philip Egger on 2015-06-25

Hello,

I downloaded the package for the latest stable version of ibus, then ran

tar -xvf ibus-pinyin_1.5.0.orig.tar.gz

cd ibus-pinyin-1.5.0

./configure

I expected the configure script to produce a makefile but it didn't, instead giving the error message

checking for IBUS... no
configure: error: Package requirements (
    ibus-1.0 >= 1.3.99
) were not met:

No package 'ibus-1.0' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables IBUS_CFLAGS
and IBUS_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.

What do I need to do to get my makefile?

Thanks,

Philip

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ibus-pinyin Edit question
Assignee:
No assignee Edit question
Last query:
2015-06-25
Last reply:
2015-06-25

Have you looked for a PPA, it may make things easier for you

Manfred Hampl (m-hampl) said : #2

Some ideas:

You might also need the files with the Debian/Ubuntu modifications in the ibus-pinyin_1.5.0-3ubuntu1.debian.tar.gz file, to enable that the compilation works as expected (e.g. the rules files contains ... --libexecdir=/usr/lib/ibus ..., which might be relevant here).

For some general information see https://help.ubuntu.com/community/CompilingSoftware

To get the build dependencies (=packages required during compilation) installed, you should execute
sudo apt-get build-dep ibus-pinyin
(this installs the packages required for compiling the ibus-pinyin package in the version for your Ubuntu release, I assume that those required by the 1.5.0 version are quite similar to these).

The one missing for you might be the package libibus-1.0-dev

Can you help with this problem?

Provide an answer of your own, or ask Philip Egger for more information if necessary.

To post a message you must log in.