iBus installed w/ Chinese Pinyin but "[Invalid UTF-8]" results on selection of characters

Asked by Cedric Bhihe on 2014-06-19

IBus: version 1.5.0 is correctly installed as part of TT 14.04 (LTS).
Fonts: ipafont-gothic and ipafont-mincho are installed.
Japanese Anthy text entry: works well
Chinese SunPinyin text entry: works well but not an acceptable option for this user
Chinese Pinyin: fails <-- ***

The whole gui seems to work perfectly well, setting of preferences, English full width text entry and toggling between English and Chinese Pinyin entry with the shift key.

Chinese Text entry (apparently) is well configured with my choice of "Chinese Pinyin". Pinyin entry actually works and iBus actually reacts well to "nihao", by proposing "你好" in return (this was pasted from a translation website, not generated by this iBus !) .
However selecting that choice with the space bar, results invariably in "[Invalid UTF-8]".
 (even after multpiple reboots & restarts of iBus)

Does someone know what goes on here ?

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ibus-pinyin Edit question
Assignee:
No assignee Edit question
Last query:
2014-06-20
Last reply:
2014-11-16

I suggest you report a bug

Cedric Bhihe (cedric-bhihe) said : #2

Some more info on the system env to better document the report filed above:

> lsb_release -a
No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 14.04 LTS
Release: 14.04
Codename: trusty
> uname -a
Linux XXX 3.13.0-27-generic #50-Ubuntu SMP Thu May 15 18:06:16 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux
> id # in case that helps
uid=1000(ckb) gid=1000(ckb) groups=1000(ckb),4(adm),24(cdrom),27(sudo),30(dip),46(plugdev),108(lpadmin),124(sambashare)

John Kuang (xiphosurus) said : #3

Hi Cedric, I just ran into this problem you described where the chinese shows up as you type, but after hitting space it becomes "[Invalid UTF-8]". After much trial and error, I realized that it is because it somehow got set to "full width". Once I manage to set it back to "half width", the problem went away.

Now, the difficult part will be setting it to half width. For some reason, you cannot change this option in the language selector options that is in the menu bar. It has to be set using the floating bar at the input prompt, which shows up sometimes, but not all the time. I have yet to figure out what triggers it show up only sometimes. Hope this helps.

Observer (dbvweb) said : #4

It affects me too. The half width method works as well.

你好

Intelligent Pinyin works perfectly.

Observer (dbvweb) said : #5

It affects me too. The half width method works as well.

你好

Intelligent Pinyin works perfectly.

Can you help with this problem?

Provide an answer of your own, or ask Cedric Bhihe for more information if necessary.

To post a message you must log in.