ia32-libs in Launchpad

Asked by Adrián Arroyo Calle on 2012-06-25

I want to submit my program to Launchpad but my program needs wxWidgets libraries. Then, I compile in my computer (Ubuntu 32 bits) and I make the package. In Launchpad, the i386 version it's good, but amd64 it's bad. I put in Depends ia32-libs-multiarch, but I've got the same error.

dpkg-shlibdeps: error: couldn't find library libgtk-x11-2.0.so.0 needed by debian/agendacorreosdivelso/usr/bin/agendacorreos (ELF format: 'elf32-i386'; RPATH: '').

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ia32-libs Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-27
Last reply:
2012-11-24
Sam_ (and-sam) said : #1

Please note #12 from bug 900512

No, I haven't got this problem. In i386, ia32-libs-multiarch it's good. But in amd64 it's bad. I see in the log this:
Setting up ia32-libs-multiarch:i386 (20090808ubuntu26) ...
But I think that I need the amd64 version.

Sam_ (and-sam) said : #3

The 64 package was a transitional ia32-libs package.
http://packages.ubuntu.com/precise-updates/ia32-libs

pichel30 (pichel30) said : #4

#dpkg --add-architecture i386
#apt-get update
#apt-get install ia32-libs

Original source:

http://askubuntu.com/questions/210054/cant-install-wine-or-ia32-libs-in-ubuntu-12-10-64-bit

this solve problems whit:
wine
skype
ia32-libs-multiarch

Can you help with this problem?

Provide an answer of your own, or ask Adrián Arroyo Calle for more information if necessary.

To post a message you must log in.