ia32-libs-multiarch but it is not installable

Asked by Fernando Miguel on 2012-06-21

 ia32-libs : Depends: ia32-libs-multiarch but it is not installable
 vim-addon-manager : Depends: ruby
 vim-gtk : Depends: libruby1.8 (>= 1.8.7.352) but it is not going to be installed
           Depends: tcl8.5 (>= 8.5.0) but it is not going to be installed

ProblemType: Bug
DistroRelease: Ubuntu 12.10
Package: ia32-libs 20090808ubuntu36
ProcVersionSignature: Ubuntu 3.4.0-5.11-generic 3.4.0
Uname: Linux 3.4.0-5-generic x86_64
ApportVersion: 2.2.3-0ubuntu4
Architecture: amd64
Date: Fri Jun 22 00:00:29 2012
Dependencies:

InstallationMedia: Ubuntu 12.10 "Quantal Quetzal" - Alpha amd64 (20120606.2)
SourcePackage: ia32-libs
UpgradeStatus: No upgrade log present (probably fresh install)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu ia32-libs Edit question
Assignee:
No assignee Edit question
Last query:
2012-06-21
Last reply:
2012-11-24
Steve Langasek (vorlon) said : #1

Sorry, but this is not a bug in ia32-libs. There is some reason why the dependencies of ia32-libs-multiarch are not installable on your system, but this most likely has to do with held packages on your local system - the ia32-libs package is installable in the quantal archive. Turning this into a question so you can get better support for your issue.

I suggest you report a bug. Quantal is NOT ready and NOT stable so you will get a LOT of issues like this leading up to and even after release. If you need an OS that works and is stable then I suggest you format and reinstall with Precise. If you are happy to stomach bugs and feature holes and want to report bugs to get the release ready for October then by all means use Quantal.

Its only just gone into alpha1....what did you expect!!

Really? That's your answer to someone that has been running Ubuntu +1 since day one for the last 5 years? ;-)
Chill, AP

Ofloo (ofloo) said : #4

I have the same issue with precise even though it isn't a bug, .. could anyone tell me how to gain more information about what is causing this?

$ sudo apt-get install ia32-libs
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 ia32-libs : Vereisten: ia32-libs-multiarch
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
$ sudo apt-get install ia32-libs-multiarch
Pakketlijsten worden ingelezen... Klaar
Boom van vereisten wordt opgebouwd
De status informatie wordt gelezen... Klaar
Sommige pakketten konden niet geïnstalleerd worden. Dit kan betekenen dat u
een onmogelijke situatie gevraagd hebt of dat u de 'unstable'-distributie
gebruikt en sommige benodigde pakketten nog vastzitten in 'incoming'.
De volgende informatie helpt u mogelijk verder:

De volgende pakketten hebben niet-voldane vereisten:
 ia32-libs-multiarch:i386 : Vereisten: libglapi-mesa:i386 maar het zal niet geïnstalleerd worden
                            Vereisten: libglu1-mesa:i386 maar het zal niet geïnstalleerd worden
                            Vereisten: libqt4-opengl:i386 maar het zal niet geïnstalleerd worden
                            Aanbevelingen: libgl1-mesa-glx:i386 maar het zal niet geïnstalleerd worden
E: Kan problemen niet verhelpen, u houdt defecte pakketten vast.
$

pichel30 (pichel30) said : #5

#dpkg --add-architecture i386
#apt-get update
#apt-get install ia32-libs

Original source:

http://askubuntu.com/questions/210054/cant-install-wine-or-ia32-libs-in-ubuntu-12-10-64-bit

this solve problems whit:
wine
skype
ia32-libs-multiarch

Can you help with this problem?

Provide an answer of your own, or ask Fernando Miguel for more information if necessary.

To post a message you must log in.