Cannot install ia32-lib on Ubuntu 7.10 64 bit

Asked by Dimach on 2007-10-19

Hi, All

Was wondering if someone could help with ia32-libs. I had it working on Ubuntu 7.04.

<code>
dimach@m6300:/usr/local/hitachi-7.0$ sudo apt-get install ia32-libs
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  ia32-libs: Depends: lib32gcc1 but it is not installable
             Depends: lib32stdc++6 but it is not installable
             Depends: lib32asound2 but it is not installable
             Depends: lib32ncurses5 but it is not installable
E: Broken packages
</code>

FYI. I'm getting a lot of E:Broken packages errors with 7.10. Should I just try to reinstall?
I was using alternative CD to install it.

Thank you for the help.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu ia32-libs Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2007-10-19
Last query:
2007-10-19
Last reply:
2007-10-19
Dimach (4me-dimach) said : #1

Here is more info:

dimach@m6300:$ sudo apt-get install lib32gcc1 lib32stdc++6 lib32asound2 lib32ncurses5
Reading package lists... Done
Building dependency tree
Reading state information... Done
Package lib32gcc1 is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
E: Package lib32gcc1 has no installation candidate

dimach@m6300:~$ dpkg --audit
dimach@m6300:~$

Dimach (4me-dimach) said : #2

dimach@m6300:~$ uname -a
Linux m6300 2.6.22-14-generic #1 SMP Sun Oct 14 21:45:15 GMT 2007 x86_64 GNU/Linux

Best Cesare Tirabassi (norsetto) said : #3

Most probably the mirror you are using is not up to date. Try again in half an hour or so and it should be ok.

Dimach (4me-dimach) said : #4

I switched back to us.archive.ubuntu.com and everything works (slow, but works). Thank you very much!!!

Dimach (4me-dimach) said : #5

Thanks Cesare Tirabassi, that solved my question.