I have Ubuntu 20.04 there's no pyqt4. it is required for install fix pls

Asked by Alex on 2020-04-28

Missing Required Dependencies
-----------------------------
error: 'libcups2' package is missing/incompatible
error: 'python3-pyqt4' package is missing/incompatible
error: 'gtk2-engines-pixbuf' package is missing/incompatible

Missing Optional Dependencies
-----------------------------
error: 'python3-notify2' package is missing/incompatible
error: 'python3-dbus.mainloop.qt' package is missing/incompatible

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2020-04-28
Last reply:
2020-04-28

sudo apt-get install python3-dev
sudo apt-get install python3-notify2

Source:
https://forums.linuxmint.com/viewtopic.php?t=222461

Manfred Hampl (m-hampl) said : #2

qt4 is obsolete and has been succeeded by qt5, see also https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=946935
An example: python3-pyqt4 has been replaced by python3-pyqt5

If you have a certain program that still depends on the old libraries, then that program has to be reworked.
Which software is it that requires qt4 on Ubuntu 20.04? Is it HPLIP?
HPLIP as provided from the hp web pages, has not yet been modified to work with Ubuntu 20.04
You should install the version of hplip provided in the Ubuntu repositories, e.g. with the command

sudo apt install hplip hplip-gui

Can you help with this problem?

Provide an answer of your own, or ask Alex for more information if necessary.

To post a message you must log in.