hplip and hpcups 3.16.3 blue background

Asked by Lucas M. on 2019-02-22

Hello,

We've been using hplip under Ubuntu 16.04.6 LTS for the time being without any problems but suddenly (just over night, not even a software upgrade) this changed. We have couple of HP Officejet Pro 8100 and 8210 USB connected printers at office and they all started to print blue backgrounds where they shouldn't. Imagine a normal text document on screen with white but it prints blue background.

It was possible with 8210 to workaround this issue by swapping driver to Generic Post Script (provided as option under Drivers list at Ubuntu standard Printer Properties dialog) but this was available only for 8210, the 8100 is going nuts with this when Generic Manufacturer and any Generic Post Script driver selected (Post Script option under recommended Drivers list isn't available for this model).

Tried removing hplip and used standard ubuntu drivers like: cups+gutenprint v5.2.11, cdj550, foomatic/pcl3. After spending few hours on wasting paper and setting up proper resolutions - prints where camming out clean (without blue background) but unfortunately there was offset of around 10mm from top of page comparing to other printers in office.

Also tried upgrading hplip to newest from hp developer pages - same blue background.

Would really appreciate if somebody could point me into direction on how this could be investigated ?

Many thanks,
Lucas.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Solved by:
Manfred Hampl
Solved:
2019-02-25
Last query:
2019-02-25
Last reply:
2019-02-23

If you install the latest HPLIP from the HPLIP site (Use the ".run" file, mark it as excutable and run it as user (not using sudo)).

Does this help?

Lucas M. (maquowicz) said : #2

Yeh runnded it as user. But 100% positive it did asked for su passwd in the process.

David Lupo (s-david-k) said : #3

The driverless cups-filters ppd (drvless.ppd) seems to work better than the hplip one, although it was stalling before the end of the page until I switched from USB to IPP connection. Over Wifi the printouts are completing, and the backgrounds are no longer blue.

It's your user password it asked for. There is no "su password"

lol I have the same issue sins this week
WTF ...

Im using this printer for more then a year
I was printing the printer testpage and it was also blue (with the text of testpage)

When I printed on the printer self testpage, it was normal white with text

I'm always using the IPP socket connection for printing

Printer HP 7510 wide (all-in-one)
Driver: hp-officejet_7510_series.ppd
Driver Version: 3.16.3
Ubuntu 16.04

If you boot the Ubuntu install CD for 16.04 and select to try the OS does it print OK?

I have updated my driver to hplib 3.19.1 and it is still BLUE ... :(

Manfred Hampl (m-hampl) said : #8

Probably bug #1817308

Pete (9-pete) said : #9

I have an HP OfficeJet Pro 6970 which started producing pages with blue backgrounds last night. Looks like I'm not the only one!

Workaround for mono-colour printing: Simply go into the HPLIP device manager, select the printer, select the "Print Settings" tab, select "General" and set "Output Mode" to "Black Only Grayscale". This can also be done from the print dialogue for most software.

I've now run out of Cyan ink, so can't do any more testing! Please can someone investigate and tell us what is going on.

I have swiched my printer away from my server to other host where I have ubuntu 18.10 and hplip 3.18.7
That is working great

Manfred Hampl (m-hampl) said : #11

If it is caused by bug #1817308 then the problem is not the Ubuntu release or the version of HPLIP, but a recent upgrade of ghostscript which caused a regression.
For details see the bug report.

Lucas M. (maquowicz) said : #12

Thank you all for the attention. Will confirm it Monday.

Best Manfred Hampl (m-hampl) said : #13

A new version of the ghostscript packages (last digit of the version number being .6) has been published an hour ago. This package is supposed to solve the problem by reverting to the status as it was before.

Lucas M. (maquowicz) said : #14

Thanks Manfred Hampl, that solved my question.