HP LaserJet 1018 Printer

Asked by volkanozturk on 2007-05-16

I have installed and set up the driver for HP LaserJet 1018 printer. It automaticaly recognizes the printer properly. In addition i can add the printer correctly. However afterwards it does not react anymore when i want to print something.

Please help me...:)

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2007-05-16
Last reply:
2009-10-16
Massimo Forti (slackwarelife) said : #1

Thanks for your question. You can post what you have done to setup the printer and you can post your ubuntu version. Thanks

volkanozturk (ozturkvolkan) said : #2

I am using Ubuntu 7.04. I downloaded the driver and showed the path in Printer Connection Window. It automatically sees the printer and it says it is ok. But when i try to print something the printer doesn't react.

Thank you very much for your attention...

Massimo Forti (slackwarelife) said : #3

Thanks. But you have used the add printer procedure of ubuntu 7.04. The driver have you downloaded is a ppd file ??? Thanks

volkanozturk (ozturkvolkan) said : #4

Yes exactly pdd file. i followed the procedure for 7.04.

Thanks a lot

Ralph Janke (txwikinger) said : #5

Try to use hplip-toolbox to setup the printer. It usually work very well, especially with HP printers. You can install it by installing the package hplip

You must install additional firmware for your printer as described here: https://bugs.launchpad.net/ubuntu/+source/foo2zjs/+bug/96454.

Amr Hassan (amr-hassan) said : #7

try:
sudo hp-setup

it just worked perfectly for me. hope it continues that way after rebooting.

jithin.l.r (jithin-l-r) said : #8

HP Linux Imaging and Printing System (ver. 3.9.2)
Printer/Fax Setup Utility ver. 8.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

when i run in terminal it says so what should i do

jithin.l.r (jithin-l-r) said : #9

HP Linux Imaging and Printing System (ver. 3.9.2)
Printer/Fax Setup Utility ver. 8.0

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

warning: Qt/PyQt 4 initialization failed.
error: hp-setup requires GUI support (try running with --qt3). Also, try using interactive (-i) mode.

when i run in terminal it says so what should i do

Workaround for Ubuntu 9.10

aptitude install hplip-gui

Can you help with this problem?

Provide an answer of your own, or ask volkanozturk for more information if necessary.

To post a message you must log in.