I have ubuntu 12.04 with HP 1020 printer gives "Device communication error ".

Asked by Jagdish on 2015-09-17

I have ubuntu 12.04 with HP Laserjet M128FN MFP over the LAN + HP Laserjet 1020 printer usb connected. The HP 128FN working ok over lan, printing & scanning both ok but in HP 1020 printer not working. Its gives "Device communication error" after successful installation. few times its work but after some time the same error occurred and nothing will be happened....Please help. I tried many HPLIP version for both printers but HP Laserjet 1020 printer not working. I also tried to installed through HP Device manager, terminal hp-setup, run the ho-doctor command but nothing would be happen....Please answer with positive reply.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2015-10-08
Last reply:
2015-10-08
Jagdish (jagdish-tamboli) said : #2

Dear Mark, I tried this sol'n for HP1020+ its installed but what about my HP 128FN printer. Its removed. I am unable to print/scan from this.............pls suggest.

As far as I know, the foo2zjs drivers replace the buggy hplip drivers, whenever there are issues with the hplip drivers. I have never tried installing and using both printer drivers at the same time.

You can try installing the hplip drivers again for your HP 128FN printer, but I expect driver conflicts (between foo2zjs and hplip) and issues if you try to enable both at the same time.

Maybe better to use 2 different printers that don't need hplip and foo2zjs at the same time.....

There is no third printer driver for any of those 2 printers you have there, as far as I know.

Jagdish (jagdish-tamboli) said : #4

Dear Mr. Mark, will you please provide me the uninstall procedure of the foo2zjs drivers.

Can you help with this problem?

Provide an answer of your own, or ask Jagdish for more information if necessary.

To post a message you must log in.