HPLIP gives error "device communication error" -> HP Laser Jet Printers 1020 and P1005 not working in Ubuntu 15.04

Asked by srikumar on 2015-04-27

Ubuntu 15.04
HP Laser Jet Printers 1020 and P1005

after upgrading to Ubuntu 15.04 both the printers are not working
what is to be done?

thank you
srikumar

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Solved by:
srikumar
Solved:
2016-10-20
Last query:
2016-10-20
Last reply:
2016-10-10

This question was reopened

srikumar (ssrikumar) said : #1

Have downloaded HPLIP 3.15.4.run onto my desktop.
The terminal message is as follows:-

srikumar@srikumar-desktop:~$ sh hplip-3.15.4.run
sh: 0: Can't open hplip-3.15.4.run
srikumar@srikumar-desktop:~$

How to proceed?

Your PhD isn't your desktop when you ran the command. You need to run:

cd ~/Desktop

Then run your command. Linux is very case sensitive so use TAB to autocomplete the filename.

srikumar (ssrikumar) said : #3

tried that & the result is:-

srikumar@srikumar-desktop:~$ cd~/Desktop
bash: cd~/Desktop: No such file or directory
srikumar@srikumar-desktop:~$

srikumar (ssrikumar) said : #4

transferred the file to the "home" and now it is working. Will let you know whether any further assistance is required.

Thank you.

Please mark as solved if it is so. The command you ran didn't work because you botched it. You ran:

cd~/Desktop

But I advised:

cd ~/Desktop

You missed the space. If you COPY and paste the commands given, you are less likely to run an incorrect command. Why do you think I give the exact command to run???

srikumar (ssrikumar) said : #6

Thank you.

The HP P1005 printer works.
However the Printer HP 1020 does not work and is not recognized by HPLIP.
The "Systems Settings" also does not show the HP 1020 printer which is connected to the USB port.
It is also not recognized on boot up.

Any way of finding out what USB ports are recognized by the system and the devices connected to each port?

srikumar (ssrikumar) said : #7

HPLIP indicates a "device communication error" for printer HP P1005 - therefore cannot download firmware for this printer nor update the plug -in.

srikumar (ssrikumar) said : #8

How to remove HPLIP 3.15.4.
Maybe I should clean up and then re-install.

hplip is in a default install. Just reinstall the package using software centre or apt-get

I suggest uninstalling the buggy hplip drivers and not reinstalling them.

For your 1020 printer: try this procedure instead:

https://mark911.wordpress.com/2014/10/31/how-to-install-printer-drivers-for-hp-laserjet-1020-in-ubuntu-14-04-lts-without-needing-access-to-openprinting-org-website/

For your P1005 printer, the installation procedure is probably similar, but the P1005 needs the foo2xqx driver instead of the foo2zjs driver.

http://foo2xqx.rkkda.com/

srikumar (ssrikumar) said : #11

Thanks Mark Rijckenberg, that solved my question.

srikumar (ssrikumar) said : #12

wow, that was awesome. It worked like a dream. Thank you very much.
Both printers are now working.

A sub directory "foo2zjs" was created. Is this required or can it be deleted.

I also wish to delete the "hplip-3.15.4" sub directory since this is no longer needed. How to do this.

Than you & God Bless.

I suggest leaving the foo2zjs directory as is.

You can use the rm command to delete subdirectories.

The exact syntax depends on where the hplip-3.15.4 subdirectory is located.

Here is more info about using the command line and about using Ubuntu:

http://manpages.ubuntu.com/manpages/precise/en/man1/rm.1.html

http://explainshell.com/explain?cmd=rm

https://help.ubuntu.com/community/ExternalGuides

If you still require help in deleting the hplip directory, I suggest creating a new question for it, because the original issue is solved.

srikumar (ssrikumar) said : #14

This question is solved and closed.
Thank you.

srikumar (ssrikumar) said : #15

A fresh install of Ubuntu 16.04 was done on a new hard disk after the old one crashed.
The Printers HP 1020 and HP P1005 do not work.

Could the same procedure suggested by Mark R. in item #10 above work again.

Thank you.

srikumar (ssrikumar) said : #16

went through the process in #10 above.
The HP P1005 Printer works.
But the Hp 1020 Printer still does not work.

any suggestions?

srikumar (ssrikumar) said : #17

This question may be closed, since a new question was opened re Ubuntu 16.04

srikumar (ssrikumar) said : #18

on running #10 for the HP 1020 Printer the following error messages arise on running the last command:-

ssrikumar@ssrikumar-OEM:/tmp/foo2zjs$ tail /var/log/syslog
Oct 10 12:36:11 ssrikumar-OEM colord[824]: (colord:824): Cd-WARNING **: CdMain: failed to emit DeviceAdded: failed to register object: An object is already exported for the interface org.freedesktop.ColorManager.Device at /org/freedesktop/ColorManager/devices/sysfs_Hewlett_Packard_HP_LaserJet_1020
Oct 10 12:36:11 ssrikumar-OEM colord-sane: io/hpmud/musb.c 2098: Invalid usb_open: Permission denied
Oct 10 12:36:11 ssrikumar-OEM colord-sane: io/hpmud/musb.c 2098: Invalid usb_open: Permission denied
Oct 10 12:36:26 ssrikumar-OEM dbus[687]: [system] Activating via systemd: service name='org.freedesktop.hostname1' unit='dbus-org.freedesktop.hostname1.service'
Oct 10 12:36:26 ssrikumar-OEM systemd[1]: Starting Hostname Service...
Oct 10 12:36:26 ssrikumar-OEM dbus[687]: [system] Successfully activated service 'org.freedesktop.hostname1'
Oct 10 12:36:26 ssrikumar-OEM systemd[1]: Started Hostname Service.
Oct 10 12:36:45 ssrikumar-OEM dbus[687]: [system] Activating service name='org.opensuse.CupsPkHelper.Mechanism' (using servicehelper)
Oct 10 12:36:45 ssrikumar-OEM dbus[687]: [system] Successfully activated service 'org.opensuse.CupsPkHelper.Mechanism'
Oct 10 12:36:45 ssrikumar-OEM colord[824]: (colord:824): Cd-WARNING **: failed to get session [pid 4655]: No such device or address
ssrikumar@ssrikumar-OEM:/tmp/foo2zjs$

any suggestions on correcting the errors.
Thank you.

What is the output of:

groups

Thanks

srikumar (ssrikumar) said : #20

ssrikumar@ssrikumar-OEM:~$ groups
ssrikumar adm cdrom sudo dip plugdev lpadmin sambashare
ssrikumar@ssrikumar-OEM:~$

Thank you.

srikumar (ssrikumar) said : #21

Is any further information required.

Thanks

srikumar (ssrikumar) said : #22

Upgraded to Ubuntu 16.10 this morning.
Printers still do not work.

any suggestions?
Thank you.

srikumar (ssrikumar) said : #23

This question is closed.