Error: Unable to locate models.dat file

Asked by Huckelberry Finne on 2013-09-29

I've got Ubuntu 10.04 running on an offline system and have a new HP Deskjet 1000 j110a. I've installed HPLIP via Synaptic with all required dependencies. Pretty much no matter what command I run (hp-setup, hp-check...) I get "error: Unable to locate models.dat"

huckfinne@huckfinne-laptop:~$ hp-check -t
error: Unable to locate models.dat file

HP Linux Imaging and Printing System (ver. 0.0.0)
Dependency/Version Check Utility ver. 14.3

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Note: hp-check can be run in three modes:
1. Compile-time check mode (-c or --compile): Use this mode before compiling the HPLIP supplied tarball (.tar.gz or .run) to
determine if the proper dependencies are installed to successfully compile HPLIP.
2. Run-time check mode (-r or --run): Use this mode to determine if a distro supplied package (.deb, .rpm, etc) or an already
built HPLIP supplied tarball has the proper dependencies installed to successfully run.
3. Both compile- and run-time check mode (-b or --both) (Default): This mode will check both of the above cases (both
compile- and run-time dependencies).

Saving output in log file: hp-check.log

Initializing. Please wait...
/Traceback (most recent call last):
  File "/usr/bin/hp-check", line 206, in <module>
    core.init()
  File "/usr/share/hplip/installer/core_install.py", line 410, in init
    self.distro_name = self.distros_index[self.distro]
KeyError: 0

Thank you for any help.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2013-10-01
Last reply:
2013-10-01

Please read this:

https://wiki.ubuntu.com/Releases

I assume you are using Ubuntu 10.04 LTS Desktop edition (not server edition), which is end-of-life and not supported anymore.

I recommend performing a clean install of Ubuntu 12.04 LTS which is supported until April 2017.

What is the output of :

uname -a; apt-cache policy gedit

Thanks

Huckelberry Finne (huckfinne) said : #3

huckfinne@huckfinne-laptop:~$ uname -a; apt-cache policy gedit
Linux huckfinne-laptop 2.6.32-21-generic #32-Ubuntu SMP Fri Apr 16 08:10:02 UTC 2010 i686 GNU/Linux
gedit:
  Installed: 2.30.0git20100413-0ubuntu1
  Candidate: 2.30.0git20100413-0ubuntu1
  Version table:
 *** 2.30.0git20100413-0ubuntu1 0
        500 http://archive.ubuntu.com/ubuntu/ lucid/main Packages
        100 /var/lib/dpkg/status

I originally had 12.04 on there, but I couldn't get Bitcoin Armory to install. Bitcoin Armory is designed for 10.04. I tried several times to install 10.04 server, but couldn't get it working on my Acer Aspire One. I've got Bitcoin Armory working on 10.04 with the only issue inability to print. I can always write down my paper backups by hand if need be, so the printing isn't strictly necessary. However, it would be much better to not have to rely on my handwritting.

Lucid is EOL on the desktop. There are zero packages for it and zero support from the community in any way.

Can you help with this problem?

Provide an answer of your own, or ask Huckelberry Finne for more information if necessary.

To post a message you must log in.