unable to print documents

Asked by huw morgan on 2012-07-17

After upgrading to 12.04, am unable to print anything. The system appears to recognise the printer but thats all. Have tried to delete and then add the printer anew - no result.

The printer is a HP Laserjet P1005. No problems with same printer on earlier versions of Ubuntu.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Solved by:
huw morgan
Solved:
2012-07-21
Last query:
2012-07-21
Last reply:
2012-07-21

Which release did you upgrade from?

huw morgan (huw-morgan-dadeni) said : #2

Hi

To provide the full story...

On this relevant partition on my PC, I have gradually progressed from 10.04 all the way through to 12.04. So the direct answer to your request is - I upgraded from 11.10.

I have repeatedly deleted the printer and then re installed it a number of time - always unsuccessfully albeit without any errors or warnings from the system during the process. It seems happy enough throughout apart from failing to print.

I also operate a newly upgraged 12.04 version on another partition. (from 11.10) In this case, as soon as I plugged the printer into the USB port, the system recognised it and went off on it's own accord to download a driver. A large pop up box similar to a terminal window appeared and I was prompted to select one of three options, one of which was to download online ('d' to select) This proceeded until I was prompted to accept a license agreement, and then completed. Printer worked OK

Also have a netbook which I recently upgraded from 11.10 to 12.04. Plugged the printer in....and it followed the same sequence as the second PC partition above - but this time was accompanied by a pop up box that requested my username and password. I entered both several times - I guarantee each one correct - but all attempts were rejected as incorrect. This did not affect the download sequence which completed successfully - printer worked OK.

So, three different results in 3 cases.

If you remove the printer in printer settings then turn off the device and reboot. Once you log in again, let the OS settle and power on the printer so it detects.

Is it ok then?

huw morgan (huw-morgan-dadeni) said : #4

Tried that. Did not see the PC reacting to switching the printer on (unlike it reacts in the other two instances previously described)

On opening Settings/Printing the pop up box shows the HP LaserJet P1005 as an icon with a green tick mark. Opened Properties and set off a test print with same fail to print as before.

I'm not sure if the two successfull 'systems' downloaded a plugin or a driver. Seems odd that one of these instances was on a different instance of 12.04 but on the same hardware.

Try removing the printer and turning it off. Then grab the latest HPLIP .run file and mark it as executable. Run it in terminal without sudo and it will install. Then reboot and power on the printer

huw morgan (huw-morgan-dadeni) said : #6

Bit of a language / knowledge barrier here!

Where / how do I get to 'grab' HPLIP.run file?

I know how to open a terminal, but what directory should I be in? Will I need to copy the file into another directory etc etc?

My knowlrdge of Unix is minimal and aquired through neccessity along the way of getting my 'user' level work done (when I was in employment). Responsible experienced Unix programmers were readily available to guide and supervise my limited excursions into the (to me) murky depths of the OS.

So far I have not developed any real understanding of Linux as piecemeal information obtained while trying to resolve issues such as this tends to increase my confusion rather than learning!

huw morgan (huw-morgan-dadeni) said : #7

In reply to an e-mail from macobra...

Don't quite know what you mean by:

'Project: gnome-media in Ubuntu => hplip in Ubuntu'

a bit cryptic to me, but I have searched for a HPLIP.run file and cannot find it.

gnome-media contains 5 files:

AUTHORS
changelog.Debian.gz
copyright
NEWS.gz
README

thats the lot

Remove the printer and power it off, then run:

cd $HOME
wget http://prdownloads.sourceforge.net/hplip/hplip-3.12.6.run
chmod +x ./hplip/hplip-3.12.6.run
./hplip/hplip-3.12.6.run

And it will install. Reboot after install and power on the printer so that it detects.

HTH

huw morgan (huw-morgan-dadeni) said : #9

Hi Actionparsnip

The wget ran OK and downloaded a 20M file

chmod +x failed with 'No such file or directory'

I managed to find the file hplip-3.12.6.run in the Home directory (no sub folders in path) and chmod it to executable

Tried to run it but it fails on 'command not found'

Did the wget command pass?

wget appears to have worked OK and dropped a 20M file hplip-3.12.6.run in my home directory. Is this where it should be?

I have changed permissions to executable. In the terminal window the file is shown in a green colour.

On entering:

hplip-3.12.6.run followed by <carriage return>

It fails to run giving 'command not found' as the reason.

I remember some unix idiosyncracy to do with name convention... is the '-' in the name a problem?

Need to pop out for a while - will get back on line in a couple hours. Very much appreciate your help.

you need to prefix with the 2 characters:

./

as I used, or it won't work.

Been back for a while, and your instructions followed to a successfull conclusion a few minutes ago. Been quite a runaround though.

FYI - I have two logins - one is an admin level which I only use when neccessary, and my usual standard user login. This is the working metthod I have assumed implied by the advice to not login as root other than when you have to.

The sequence of running the hplip was terminated by the rejection of my password. Tried sudo but that got refused as my login is not in the sudoers file. Logged out and started from scratch with my admin login. All went well until a load of missing dependencies where found. Took about 20 mins to download and install about 20 files (including python-dev, cups-client, xsane etc etc)

Then it downloaded a plugin - this part of the sequence looked pretty much like what i'd seen happening on my second partition and on my netbook. However there were numerous failures along the way so each step had to be taken two or more times. There were numerous error reports generated which I expect have been sent to Canonical.

Anyway, problem solved - allthough the question remains as to why so much software was missing in this case.

Thanks a lot for your help and patience.