Upgrading HPLIP on Ubuntu 11.04

Asked by Vectorio on 2011-11-30

Ubuntu 11.04 contains HPLIP 3.11.1, and when I go to the Synaptic package manager, it states that the installed version ("3.11.1-2ubuntu2") is also the latest version. But that is not true, the latest version is 3.11.10. How can I upgrade to 3.11.10? I would like to do this as I am considering to buy a printer that needs that version. Easy upgrade procedure is preferred (no command line hacks if possible :-).

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2011-11-30
Last reply:
2011-11-30

You can grab the HPLIP run file, mark it as executable and run it in a terminal as user (not with sudo)

Using command line is not a "hack"

Can you help with this problem?

Provide an answer of your own, or ask Vectorio for more information if necessary.

To post a message you must log in.