My HP laser printer will not print all the letters

Asked by Peter M Le Mare on 2011-10-25

I have just downloaded 11.10 and finding several difficulties. The most important problem is that when I print a document in Libre Office some 50% of the words are mostly made up of dots, that is there are one or or two letters in a word and the ones missing are replaced by dots (it appears it may be just a d e b w h): also some of my older documents seem to be OK but I have only tried a very few so far. The page and the print preview show normal words. I have tried saving again and in a different font and also in *.doc and *.odt to no avail. Even a completely new document show the same problem.
I have found that in my printer properties if I change "PDF" to "Post Script" under 'file' - 'printer settings' - 'properties' - 'device' it appears to correct the problem BUT this will not stay set on Post Script for all documents only for the individual ones that have been changed. The system settings 'printer' does not allow one to do this. I don't know if this works for other printers as now my Epson Photo R300 will NOT work and for many years I have been unable to get my Brother scanner/copier/photo/printer DCP-315CN to work at all. Help please.

Life, love, peace and freedom Pete Le M

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Last query:
2011-10-25
Last reply:
2011-10-27

Do you want help with the Brother or the HP?

Both - and the Epson but the HP (it is laser jet 1018 - mono) is the most important at the moment. It seems to be a way of keeping the setting of Post Script so that it is for all documents. In the latest new document I have typed (not copied and pasted) the dots have been replaced with apostrophes thus ' . It must be something to do with the 11.10 upgrade and assume it may have something to do with cups or the change in cups. The Epson r300 (colour) which I have recently been given was working with 11.04 but now it just says 'processing' but no further even when refreshed and /or switched on and off. My HP with the previous version of Ubuntu often did not work i.e. receive the data if I switched it on when I switched on the computer and booted it up. This was cured by switching it off separately and switching it on: I also had to refresh the printing window and then release it if I had already gone to print.

Can you and anyone also tell me how I stop automatically logging off when I leave the computer and it goes to sleep. it did not do this with 11.04: incidentally I was using the older desktop not this that I think is called Unity.

Can you give the output of:

lsb_release -a; dpkg -l | grep hplip

Thanks

I don't know what that means or how to determine it

It's a terminal command, run it ni a terminal and paste the output here. You can copy and paste to the terminal easily

Below didn't seem to have gone. I did it as a reply e-mail so pasted below:
On 25/10/11 19:01, actionparsnip wrote:
> Your question #176147 on Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+question/176147
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> It's a terminal command, run it ni a terminal and paste the output here.
> You can copy and paste to the terminal easily
>
Is this what you require?
peter@peter-desktop:~$ lsb_release -a; dpkg -l | grep hplip
LSB Version: core-2.0-ia32:core-2.0-noarch:core-3.0-ia32:core-3.0-noarch:core-3.1-ia32:core-3.1-noarch:core-3.2-ia32:core-3.2-noarch:core-4.0-ia32:core-4.0-noarch
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
dpkg-query: warning: parsing file '/var/lib/dpkg/status' near line 42622 package 'virtualbox-3.1':
 error in Version string '3.1.2-56127_Ubuntu_karmic': invalid character in revision number
ii hplip 3.11.7-1ubuntu3 HP Linux Printing and Imaging System (HPLIP)
ii hplip-cups 3.11.7-1ubuntu3 HP Linux Printing and Imaging - CUPS Raster driver (hpcups)
ii hplip-data 3.11.7-1ubuntu3 HP Linux Printing and Imaging - data files
peter@peter-desktop:~$

Life, love, peace and freedom

Pete (Le M)

try:

wget http://prdownloads.sourceforge.net/hplip/hplip-3.11.10.run; chmod +x ./hplip-3.11.10.run; ./hplip-3.11.10.run

It will install the latest HPLIP, may help

I have tried your suggestion and re-installed HPLIP and at first I thought it had cured the problem but then later on another .doc it just left out fewer letters! However I may have solved it as I have loaded an alternative driver that is found in properties - settings. Although it is not the recommended one so far it seems to work!!

Gobnuts (gobnuts) said : #9

I have the same problem on an HP Laserjet 1022n. It printed everything just fine until the upgrade to Kubuntu 11.10. Also, I seem to have screwed up my driver in the attempt to install the newest version of HPLIP… ahem.

Will try to get this fixed and report back.

Can you help with this problem?

Provide an answer of your own, or ask Peter M Le Mare for more information if necessary.

To post a message you must log in.