Ubuntu

My linux won't enable my hp printer.

Asked by Patricia Hughes on 2011-04-15

My linux won't enable my hp officejet 4500 G510g-m, even though I've downloaded the driver, checked that the printer is recognised and online etc. My windows7 laptop has no problem; I just connected it from a USB and it works a treat. But despite hplip being set up fully, despite the printer being in sys-admin-printer, despite me having gone onto every programme I can find, linux refuses to see my printer.

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hplip Edit question
Assignee:
No assignee Edit question
Solved by:
Patricia Hughes
Solved:
2011-04-17
Last query:
2011-04-17
Last reply:
2011-04-17

Can you give the output of:

uname -a; lsb_release -a; hp-info

Thanks

Patricia Hughes (petrarch555) said : #2

Very difficult to say. I went to terminal & typed it in whereupon it spewed
out an avalanche of characters, ending with

HP Linux Imaging and Printing System (ver. 3.10.6)
Device Information Utility ver. 5.2

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Using device: hp:/usb/Officejet_4500_G510g-m?serial=CN01SD517705CQ

error: Unable to communicate with device (code=12):
hp:/usb/Officejet_4500_G510g-m?serial=CN01SD517705CQ
error: Unable to open device
hp:/usb/Officejet_4500_G510g-m?serial=CN01SD517705CQ.

Thanks for asking.

On Sat, Apr 16, 2011 at 2:35 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Needs information
>
> actionparsnip requested for more information:
> Can you give the output of:
>
> uname -a; lsb_release -a; hp-info
>
> Thanks
>
> --
> To answer this request for more information, you can either reply to
> this email or enter your reply at the following page:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

If you copy and paste the command to the terminal and press ENTER you will run the exact command, there is no need to hand type it. You can also copy and paste from the terminal to here.

You have a sligtly older hplip. I suggest you grab the latest hplip, mark it as executable and run it in terminal (without sudo).

Patricia Hughes (petrarch555) said : #4

Thanks actionp. But how do I tell what age the hplip is? And how do I run it
in terminal? (I know where terminal is, but that's all.)

On Sun, Apr 17, 2011 at 1:42 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> If you copy and paste the command to the terminal and press ENTER you
> will run the exact command, there is no need to hand type it. You can
> also copy and paste from the terminal to here.
>
> You have a sligtly older hplip. I suggest you grab the latest hplip,
> mark it as executable and run it in terminal (without sudo).
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=2
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

HP Linux Imaging and Printing System (ver. 3.10.6)

It's in your output. The latest verson is 3.11.1 so an update to the newer one may help

Patricia Hughes (petrarch555) said : #6

Yes. My linux won't enable my hp printer. It also won't enable Gnome
functions. I have skype on it, but I can't use it because it has sound but
no microphone. I have had it a month and am thinking of asking for my money
back.
On Sun, Apr 17, 2011 at 1:48 PM, Patricia Hughes <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Answered => Open
>
> You are still having a problem:
> Thanks actionp. But how do I tell what age the hplip is? And how do I run
> it
> in terminal? (I know where terminal is, but that's all.)
>
> On Sun, Apr 17, 2011 at 1:42 PM, actionparsnip <
> <email address hidden>> wrote:
>
> > Your question #152974 on hplip in Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > Status: Open => Answered
> >
> > actionparsnip proposed the following answer:
> > If you copy and paste the command to the terminal and press ENTER you
> > will run the exact command, there is no need to hand type it. You can
> > also copy and paste from the terminal to here.
> >
> > You have a sligtly older hplip. I suggest you grab the latest hplip,
> > mark it as executable and run it in terminal (without sudo).
> >
> > --
> > If this answers your question, please go to the following page to let us
> > know that it is solved:
> >
> >
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=2
> >
> > If you still need help, you can reply to this email or go to the
> > following page to enter your feedback:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > You received this question notification because you are a direct
> > subscriber of the question.
> >
>
>
> --
> Patricia
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Sound has nothing to do with a printer.....

Patricia Hughes (petrarch555) said : #8

You're right. It's something to do with the interface between hplip and
linux.

On Sun, Apr 17, 2011 at 2:28 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Sound has nothing to do with a printer.....
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=6
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Latest HPLIP may help, give it a shot

Patricia Hughes (petrarch555) said : #10

I'll try it out. Thanks for suggesting it.

On Sun, Apr 17, 2011 at 6:17 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Latest HPLIP may help, give it a shot
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=8
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Patricia Hughes (petrarch555) said : #11

I've downloaded hplip 3.11.3a (after looking it up to see if it was the
right one), typed it into the terminal & run it. All it came up with was
bash: //home/user/Desktop/hplip-3.11.3a.run: Permission denied
So much for that! Any more suggestions?

On Sun, Apr 17, 2011 at 6:33 PM, Patricia Hughes <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Answered => Open
>
> You are still having a problem:
> I'll try it out. Thanks for suggesting it.
>
> On Sun, Apr 17, 2011 at 6:17 PM, actionparsnip <
> <email address hidden>> wrote:
>
> > Your question #152974 on hplip in Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > Status: Open => Answered
> >
> > actionparsnip proposed the following answer:
> > Latest HPLIP may help, give it a shot
> >
> > --
> > If this answers your question, please go to the following page to let us
> > know that it is solved:
> >
> >
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=8
> >
> > If you still need help, you can reply to this email or go to the
> > following page to enter your feedback:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > You received this question notification because you are a direct
> > subscriber of the question.
> >
>
>
> --
> Patricia
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

ok you need to run:

chmod +x /home/user/Desktop/hplip-3.11.3a.run; /home/user/Desktop/hplip-3.11.3a.run

Patricia Hughes (petrarch555) said : #13

I've done that, but it says :Try `chmod --help' for more information. So I
did that and it said:

~$ chmod --help
Usage: chmod [OPTION]... MODE[,MODE]... FILE...
  or: chmod [OPTION]... OCTAL-MODE FILE...
  or: chmod [OPTION]... --reference=RFILE FILE...
Change the mode of each FILE to MODE.

  -c, --changes like verbose but report only when a change is made
      --no-preserve-root do not treat `/' specially (the default)
      --preserve-root fail to operate recursively on `/'
  -f, --silent, --quiet suppress most error messages
  -v, --verbose output a diagnostic for every file processed
      --reference=RFILE use RFILE's mode instead of MODE values
  -R, --recursive change files and directories recursively
      --help display this help and exit
      --version output version information and exit

Each MODE is of the form `[ugoa]*([-+=]([rwxXst]*|[ugo]))+'.

Report chmod bugs to <email address hidden>
GNU coreutils home page: <http://www.gnu.org/software/coreutils/>
General help using GNU software: <http://www.gnu.org/gethelp/>
For complete documentation, run: info coreutils 'chmod invocation'

I don't understand that, do you?

On Sun, Apr 17, 2011 at 7:30 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> ok you need to run:
>
> chmod +x /home/user/Desktop/hplip-3.11.3a.run;
> /home/user/Desktop/hplip-3.11.3a.run
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=11
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Patricia Hughes (petrarch555) said : #14

I typed in what you said and run it. It came up with:

bash: chmod+x/home/user/Desktop/hplip-3.11.3a.run: No such file or directory
bash: /home/user/Desktop/hplip-3.11.3a.run: Permission denied

On Sun, Apr 17, 2011 at 7:42 PM, Patricia Hughes <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Answered => Open
>
> You are still having a problem:
> I've done that, but it says :Try `chmod --help' for more information. So I
> did that and it said:
>
> ~$ chmod --help
> Usage: chmod [OPTION]... MODE[,MODE]... FILE...
> or: chmod [OPTION]... OCTAL-MODE FILE...
> or: chmod [OPTION]... --reference=RFILE FILE...
> Change the mode of each FILE to MODE.
>
> -c, --changes like verbose but report only when a change is made
> --no-preserve-root do not treat `/' specially (the default)
> --preserve-root fail to operate recursively on `/'
> -f, --silent, --quiet suppress most error messages
> -v, --verbose output a diagnostic for every file processed
> --reference=RFILE use RFILE's mode instead of MODE values
> -R, --recursive change files and directories recursively
> --help display this help and exit
> --version output version information and exit
>
> Each MODE is of the form `[ugoa]*([-+=]([rwxXst]*|[ugo]))+'.
>
> Report chmod bugs to <email address hidden>
> GNU coreutils home page: <http://www.gnu.org/software/coreutils/>
> General help using GNU software: <http://www.gnu.org/gethelp/>
> For complete documentation, run: info coreutils 'chmod invocation'
>
> I don't understand that, do you?
>
> On Sun, Apr 17, 2011 at 7:30 PM, actionparsnip <
> <email address hidden>> wrote:
>
> > Your question #152974 on hplip in Ubuntu changed:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > Status: Open => Answered
> >
> > actionparsnip proposed the following answer:
> > ok you need to run:
> >
> > chmod +x /home/user/Desktop/hplip-3.11.3a.run;
> > /home/user/Desktop/hplip-3.11.3a.run
> >
> > --
> > If this answers your question, please go to the following page to let us
> > know that it is solved:
> >
> >
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=11
> >
> > If you still need help, you can reply to this email or go to the
> > following page to enter your feedback:
> > https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
> >
> > You received this question notification because you are a direct
> > subscriber of the question.
> >
>
>
> --
> Patricia
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

I said to run:
chmod +x /home/user/Desktop/hplip-3.11.3a.run
you ran:
chmod+x/home/user/Desktop/hplip-3.11.3a.run

See how it is different. I give the exact command so you can copy and paste it. If you mangle command you can easily break your OS.

Patricia Hughes (petrarch555) said : #16

You are right, I mangled it. I copied and pasted it onto terminal, thanks
for typing it for me.
It came up with the usual prompt. I was overjoyed, thinking my printer would
finally work now. But it didn't.

On Sun, Apr 17, 2011 at 8:28 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> I said to run:
> chmod +x /home/user/Desktop/hplip-3.11.3a.run
> you ran:
> chmod+x/home/user/Desktop/hplip-3.11.3a.run
>
> See how it is different. I give the exact command so you can copy and
> paste it. If you mangle command you can easily break your OS.
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=14
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Ok did the script run through ok?

Patricia Hughes (petrarch555) said : #18

Yes, it did. But nothing happened.

Ok then remove the current HP printer and power off the device, reboot then once logged in, power on the printer. Should be ok

Patricia Hughes (petrarch555) said : #20

I did all that. Once I had turned on the computer and the printer, amazingly
the computer printed off one sheet that I had forgotten I had queued; it was
not on the printing list. But it printed anyway. However the printer would
not print the 3 items on the printing list.
I thought that might be because they were old orders on obsolete machinery,
so I cancelled them all and tried to print off your answer. But the printer
wouldn't work again.
So it's progress of a kind: usually the printer doesn't work, but sometimes
it inexplicably decides to do its own thing. Who says computers aren't
intelligent?

On Sun, Apr 17, 2011 at 9:15 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> Status: Open => Answered
>
> actionparsnip proposed the following answer:
> Ok then remove the current HP printer and power off the device, reboot
> then once logged in, power on the printer. Should be ok
>
> --
> If this answers your question, please go to the following page to let us
> know that it is solved:
>
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974/+confirm?answer_id=18
>
> If you still need help, you can reply to this email or go to the
> following page to enter your feedback:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

hmm, strange. Not sure then. Maybe others can pitch in

Patricia Hughes (petrarch555) said : #22

I've found the solution!!!!

I have to change the printer when it's checking which one to use. I have
about half a dozen different versions of the same printer because I kept
putting new ones on, but only one is ready to use. As long as I tell it
which one to use (and eventually get rid of the unusable ones) it works very
well!!!

I can only say thank you, without your help I don't know what I would have
done by now. Can I recommend you to someone?

On Sun, Apr 17, 2011 at 10:04 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> actionparsnip posted a new comment:
> hmm, strange. Not sure then. Maybe others can pitch in
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Patricia Hughes (petrarch555) said : #23

I don't know how to correct the error.

I'd like to thank actionparsnip for helping me to make my hp printer work. If it hadn't been for his patience and logic I'd have given my linux to the dustbinman ages ago. He really deserves a big hug.

Patricia Hughes (petrarch555) said : #24

I'd like to confirm that actionparsnip helped me to find an answer to my computer/printer problem.

Glad you got the gold which is all we want :D

Have whomever you intend to "recommend me to" to post a question on here and the community will help.

Patricia Hughes (petrarch555) said : #26

I'll tell my friend. You deserve a pay rise. (Show this to your boss.)

On Mon, Apr 18, 2011 at 1:31 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> actionparsnip posted a new comment:
> Glad you got the gold which is all we want :D
>
> Have whomever you intend to "recommend me to" to post a question on here
> and the community will help.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

I'm simply a contributing volunteer. There is no pay here. People like myself just try to help the community to make people's experience better. This is the same for most of the people who code the apps you are currently using and they only get money by donations from kind users (like yourself).

Patricia Hughes (petrarch555) said : #28

Well, as a volunteer you are certainly contributing! What does "coding the
apps" mean? Is it a new language?

On Mon, Apr 18, 2011 at 2:20 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> actionparsnip posted a new comment:
> I'm simply a contributing volunteer. There is no pay here. People like
> myself just try to help the community to make people's experience
> better. This is the same for most of the people who code the apps you
> are currently using and they only get money by donations from kind users
> (like yourself).
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Coding the apps means sitting down and planning and actually making the code which makes the apps you are using. They are very skilled ad very underpaid. This contrasts harshly wit the developers at the likes of Microsoft whom get paid well. It's a shame. If you have ever done any coding in C or C++ or jAVA etc,it's that sort of thing but users all over the globe use your software.

Patricia Hughes (petrarch555) said : #30

Microsoft workers get paid very well, but they don't own what they create,
and they can be - and are - fired at a moment's notice. You don't get paid
very well, but you are honest, you DO own what you create, you can't get
sacked, and most of all you know you are DEFINITELY helping people a lot.
And I hope you make friends, not just co-workers.

On Mon, Apr 18, 2011 at 3:45 PM, actionparsnip <
<email address hidden>> wrote:

> Your question #152974 on hplip in Ubuntu changed:
> https://answers.launchpad.net/ubuntu/+source/hplip/+question/152974
>
> actionparsnip posted a new comment:
> Coding the apps means sitting down and planning and actually making the
> code which makes the apps you are using. They are very skilled ad very
> underpaid. This contrasts harshly wit the developers at the likes of
> Microsoft whom get paid well. It's a shame. If you have ever done any
> coding in C or C++ or jAVA etc,it's that sort of thing but users all
> over the globe use your software.
>
> --
> You received this question notification because you are a direct
> subscriber of the question.
>

--
Patricia

Patricia Hughes (petrarch555) said : #31

LinkedIn
------------

I'd like to add you to my professional network on LinkedIn.

- Patricia

Patricia Hughes
LanguageLearningLtd Director
Coventry, United Kingdom

Confirm that you know Patricia Hughes:
https://www.linkedin.com/e/5yip0k-h1m1abwb-3l/isd/6877652979/_1LbHI3K/?hs=false&tok=0O4Joxv7WyHRc1

--
You are receiving Invitation to Connect emails. Click to unsubscribe:
http://www.linkedin.com/e/5yip0k-h1m1abwb-3l/v8QUGvReQ7X6mF4rshxY5nR0KLu523_diC40c64ZnwkUmU4oRapket/goo/question152974%40answers%2Elaunchpad%2Enet/20061/I2366764506_1/?hs=false&tok=3v9HiM-y6yHRc1

(c) 2012 LinkedIn Corporation. 2029 Stierlin Ct, Mountain View, CA 94043, USA.