Hibernate/Suspend and Not wake-up

Asked by ARUN KUMAR P K on 2012-05-05

1.My system will not wake-up after Hibernate/Suspend.(Sometimes the system get automatically Suspended,especially when my 3G (D-Link DWM 156) modem connected.)
2.This modem not even detecting in Ubuntu 12.04.(So,I degraded to 11.10)

My /etc/pm/sleep.d is shown below.

http://paste.ubuntu.com/969485/
http://paste.ubuntu.com/969495/
http://paste.ubuntu.com/969553/

System Details :
Asus x44H
Intel (R) Core (TM) i3-2230M CPU @ 2.20GHz
Memory : 1.9 GB
Platform : i686
Distribution : Ubuntu 11.10 oneiric
Desktop Environment : Unity

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hibernate Edit question
Assignee:
No assignee Edit question
Last query:
2012-05-05
Last reply:
2012-05-05
Wyatt Smith (wyatt-smith) said : #1

Sometimes it can be very frustrating trying to resolve sleep/hibernate issues. I know this from personal experience, as I have come across numerous issues of various machines. I can give some general suggestions which have help me out in the past.

Most of the time issues are hardware related and can be solved in the bios. So for the first step, I recommend in updating the system bios. For your machine that would be v209. Next I would check all the advanced power management setting within the bios. Check the documentation related to you particular bios as sometime the solutions to your problem is known and documented. For example, on one asus machine I worked on, the bios documentation explicitly referenced a particular jumper setting and a S3 only sleep state.

If the modifications to the bios and settings do not solve the issue, I look at power management flags that can be passed as a parameter to the kernel. For testing you can manually edit the grub command line before booting and add the kernel parameter. If a setting such as noapic is solves the issue, i will permanently added it in my grub configuration.

Hope this helps

Can you help with this problem?

Provide an answer of your own, or ask ARUN KUMAR P K for more information if necessary.

To post a message you must log in.