What is causing my hd to spin down very frequently, despite setting hdparm -S?

Asked by Chu Tan on 2012-04-10

The non-OS drive of my ubuntu server (Oneiric 11.10) has been going to standby approximately after 10 mins of idle even though I've configured /etc/hdparm.conf to put APM to 255 and spindown_time to 1hr

/dev/sdb {
  apm = 255
  spindown_time = 242 # 243 1.5 hour 242 for 1hr
}

The question is, what else could be causing it to go into standby mode?

> hdparm -B /dev/sdb
/dev/sdb:
 APM_level = off
 (shows that hdparm.conf is taking effect)

Other info:
uninstalled pm-utils
installed acpid (only for the purpose of handling the power off button event)
installed noflushd (out of habit, but probably not necessary as I don't care to spin down my OS drive at all)
installed smartmontools

Files in /usr/lib/pm-utils/power.d/
95hdparm-apm
Files in /usr/lib/pm-utils/sleep.d/
01PulseAudio 60_wpa_supplicant 95hdparm-apm

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hdparm Edit question
Assignee:
No assignee Edit question
Last query:
2012-04-10
Last reply:
2012-04-10

Can you give the output of:

lsb_release -a; uname -a

Thanks

Chu Tan (chujtan) said : #2

No LSB modules are available.
Distributor ID: Ubuntu
Description: Ubuntu 11.10
Release: 11.10
Codename: oneiric
Linux audria 3.0.0-17-server #30-Ubuntu SMP Thu Mar 8 22:15:30 UTC 2012 x86_64 x86_64 x86_64 GNU/Linux

Just noticed this /etc/default/noflushd (I highly suspect it is spinning down the drives)

# Time in minutes before a disk is spun down. The disk is only spun
# down after this much time has passed without any reads from the disk.
TIMEOUT="5"

# Disks to spin down. Noflushd currently only works with ide hard disks;
# scsi disks require a kernel patch. You may spin down multiple disks by
# listing them all here separated by spaces. If this variable is unset,
# noflushd tries to auto-detect all disks on the system, and spins them
# down using the default timeout given above.
DISKS=

Have you checked in power options about the drive spindown?

Chu Tan (chujtan) said : #4

I do not have GUI installed, if that's what you are referring to by "checked in power options".

I've modified settings in etc/default/noflushd to work only on the OS drive (sda), so far, sdb hasn't gone into standby yet.

i see, let me check

Can you help with this problem?

Provide an answer of your own, or ask Chu Tan for more information if necessary.

To post a message you must log in.