Disk error messages during boot in 10.04

Asked by Goombies on 2010-07-01

After updating my motherboard BIOS, I'm now getting these error messages every time I boot up:

[ 16.157447] ata3.00: exception Emask 0x100 SAct 0x0 SErr 0x0 action 0x6
[ 16.157488] ata3.00: failed command: SET FEATURES
[ 16.157525] ata3.00: cmd ef/05:fe:00:00:00/00:00:00:00:00/40 tag 0
[ 16.157526] res 51/04:fe:00:00:00/00:00:00:00:00/40 Emask 0x1 (device error)
[ 16.157592] ata3.00: status: { DRDY ERR }
[ 16.157623] ata3.00: error: { ABRT }
[ 16.157661] ata3: hard resetting link

I've got a 200GB hard drive, using an ECS SiS 755 A2 motherboard w/1.1b BIOS.

Anyone know how to cure this?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hdparm Edit question
Assignee:
No assignee Edit question
Solved by:
Goombies
Solved:
2010-08-19
Last query:
2010-08-19
Last reply:
2010-07-18

I'd boot to liveCD and fsck each partition. You can also download the ultimate boot cd and check the disk with the manufacturers tool (The UBCD has the most used drive manufacturers tools on)

Goombies (matt-trostel) said : #2

Thanks actionparsnip,

Unfortunately there is no issue with the hard drive.

I've run fsck from the liveCD boot, as well as UBCD, and neither found any errors with the hard drive itself.

Does this appear to be an issue with the disk controller?

Goombies (matt-trostel) said : #3

And any idea why updating my motherboard's BIOS would trigger this error to show up consistently each time I power-on my system?

I'm hoping I don't need to do a clean reinstall to fix this...

Try some boot options. When you updated the BIOS did you set the BIOS to defaults?

I'd try that first, it will be a steeing within the BIOS to use failsafe defaults. May help. Testing the drive is good and we no know its software a based issue.

Goombies (matt-trostel) said : #5

Thanks again actionparsnip,

I did set the BIOS to use the failsafe defaults, and the error message persists.

None of the BIOS settings I've tweaked make any difference.

Let me know if you think of anything else to try.

damian allanson (dallnsn) said : #6

I'm seeing the same error. I have the same motherboard. It flashes on the screen as ubuntu is booting, but doesn't seem to stop the boot process.

I've just done an in place upgrade from 9.10 to 10.04 and that's when I first saw it.

The upgrade has caused another problem which may or may not be related - grub is not detecting all my bootable partitions correctly.

Goombies (matt-trostel) said : #7

I root-caused this to some sort of issue with the released version of hdparm (9.15 at the time of this posting).

After manually upgrading hdparm to 9.27, this message no longer appears during boot.

Follow the links below to do the manual install of hdparm:
32 bit: http://packages.debian.org/squeeze/i386/hdparm
64 bit: http://packages.debian.org/squeeze/amd64/hdparm