xubuntu 10.04 Lucid Lynx: HAL daemon is not running [Error]

Asked by Robert Collard on 2010-01-20

Tried "sudo /etc/init.d/hal restart" got message: "sudo: /etc/init.d/hal: command not found" HAL is supposed to be removed from Xubuntu 10.04 AMD-64 but error comes up on every restart. Tried reinstalling "Xfce Power Manager" too, it is the other line in the error message, still get error. Did not find bug like this in questions.

Dell Inspiron Laptop 1545 dual T3400 CPUs @ 2/16Ghz 3GiB RAM 160GiB HD
Xubuntu 10.04 AMD-64 Alpha 2 and Linux Mint 8 i386 KDE CE RC version dual boot.

Question information

Language:
English Edit question
Status:
Answered
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Last query:
2010-01-20
Last reply:
2010-01-20
Soul-Sing (soulzing) said : #1

sudo /etc/init.d/hal restart and the error "sudo: /etc/init.d/hal: command not.." have different syntaxes...
sudo: doesn't work, sudo /etc/init.d/hal restart should work.

Log a bug

Lucid is very early beta and you WILL get problems

Robert Collard (bobcollard) said : #3

"sudo apt-get remove hal" That was my solution and it worked. Login is super fast. Not sure if anything else was effected, though. All my applications work and I'm using it right now. Still going through all the things I usually use after a half hour of two reboots and many different programs. I did two reboots to make sure it was not a fluke, but, I don't see any difference except speed, wow. I'm adding this as a comment, if you don't think I will have any more problems then consider this solved, answer me and I will post it Solved.

Can you help with this problem?

Provide an answer of your own, or ask Robert Collard for more information if necessary.

To post a message you must log in.