Jaunty not mounting DVD's automatically, not resetting FS labels?

Asked by The Loeki on 2009-05-30

Hi,
I'm on an up-to-date Jaunty 32-bit.

There are two DVD drives in this system (dmesg output below).
The system doesn't seem to respond when plugging in any CD/DVD .

I've checked fstab and it seems allright:
/dev/sr0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/sr1 /media/cdrom1 udf,iso9660 user,noauto,exec,utf8 0 0

When I manually look up the devices in Locations they take a while to spin up, but they do eventually mount.
However, <something> (I suspect HAL, hence this question) then correctly reads the FS Label and names the volume accordingly, but the automagic never does run.
However, when ejecting the CD/DVD and inserting another (and subsequently clicking on it to get it to mount), the FS label doesn't change anymore until after reboot.

DVD drives:
[ 1.992330] ata2.00: ATAPI: DVDRW 16X16X, YTS1, max UDMA/66
[ 1.992356] ata2.01: ATAPI: DM-2000TE, 5.BVA, max UDMA/100
[ 1.992375] ata2: nv_mode_filter: 0x1f39f&0x701f->0x701f, BIOS=0x7000 (0xc700c0c0) ACPI=0x701f (60:60:0x1f)
[ 1.992379] ata2: nv_mode_filter: 0x3f39f&0x701f->0x701f, BIOS=0x7000 (0xc700c0c0) ACPI=0x701f (60:60:0x1f)
[ 2.024263] ata2.00: configured for UDMA/33
[ 2.040305] ata2.01: configured for UDMA/33
[ 2.075267] scsi 1:0:0:0: CD-ROM DVDRW 16X16X YTS1 PQ: 0 ANSI: 5
[ 2.079272] sr0: scsi3-mmc drive: 48x/48x writer cd/rw xa/form2 cdda tray
[ 2.079276] Uniform CD-ROM driver Revision: 3.20
[ 2.079364] sr 1:0:0:0: Attached scsi CD-ROM sr0
[ 2.079414] sr 1:0:0:0: Attached scsi generic sg1 type 5
[ 2.079736] scsi 1:0:1:0: CD-ROM MITSUMI DM-2000TE 5.BV PQ: 0 ANSI: 5
[ 2.082963] sr1: scsi3-mmc drive: 0x/50x cd/rw xa/form2 cdda tray
[ 2.083025] sr 1:0:1:0: Attached scsi CD-ROM sr1
[ 2.083064] sr 1:0:1:0: Attached scsi generic sg2 type 5

Help?

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
The Loeki
Solved:
2009-06-09
Last query:
2009-06-09
Last reply:
The Loeki (the-loeki) said : #1

Answer was: The guy had disabled autopolling in HAL:

hal-disable-autopolling --enable-polling --device /dev/sr0
hal-disable-autopolling --enable-polling --device /dev/sr1

Fixed the problem :D