Problem With postfix package

Asked by Danish on 2009-05-14

Hi,

   I use Ubuntu 9.04, A Few days Back i was installing a lot of packages with synaptic, I dont remember which one but i had to force quit one of the installs because it seemed to be stuck.. I still think it was really stuck.
  When ever i try to install anything now, i get something like the following

dpkg: error processing postfix (--configure):
 subprocess post-installation script returned error exit status 75

i tried to reinstall postfix by apt-get autoremove postfix

then tried to install it again using apt-get install postfix

this was the output that i got
anish@danes-Ubuntu-9:~$ sudo apt-get install postfix
Reading package lists... Done
Building dependency tree
Reading state information... Done
Suggested packages:
  procmail postfix-mysql postfix-pgsql postfix-ldap postfix-pcre sasl2-bin resolvconf postfix-cdb
The following NEW packages will be installed:
  postfix
0 upgraded, 1 newly installed, 0 to remove and 5 not upgraded.
Need to get 1219kB of archives.
After this operation, 3006kB of additional disk space will be used.
WARNING: The following packages cannot be authenticated!
  postfix
Install these packages without verification [y/N]? y
Get:1 http://in.archive.ubuntu.com jaunty/main postfix 2.5.5-1.1 [1219kB]
Fetched 1219kB in 4min 9s (4886B/s)
Preconfiguring packages ...
Selecting previously deselected package postfix.
(Reading database ... 129420 files and directories currently installed.)
Unpacking postfix (from .../postfix_2.5.5-1.1_i386.deb) ...
Processing triggers for ufw ...
Processing triggers for man-db ...
Setting up postfix (2.5.5-1.1) ...

Postfix configuration was not changed. If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed. To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run '/etc/init.d/postfix reload'.

Running newaliases
newaliases: warning: valid_hostname: numeric hostname: 1
newaliases: fatal: file /etc/postfix/main.cf: parameter mydomain: bad parameter value: 1
dpkg: error processing postfix (--configure):
 subprocess post-installation script returned error exit status 75
Processing triggers for libc6 ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
danish@danes-Ubuntu-9:~$
----------------------------------------------------------------------------------------------------------

Is postfix important? What does it do?
how do i fix this? I'm fine with linux basics, but not an expert.

Thanks for reading i hope you can help me out on this

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Dominik Zalewski
Solved:
2009-05-19
Last query:
2009-05-19
Last reply:
2009-05-18
Best Dominik Zalewski (dzalewski) said : #1

Postfix is a SMTP server. Unless you are not running a mail server you can simply: sudo apt-get purge postfix

Danish (danested) said : #2

Thank you i did what you said and installed some really small package... It worked.
It wasn't really verry serious but it was definitely annoying. Thank you so much.

Danish (danested) said : #3

Thanks Dominik Zalewski, that solved my question.