Launchpad is the only website I can access

Asked by Robert Kryder on 2007-05-14

I just installed Dapper on my laptop.
Every website I try to go to the progress bar stops with just one square left, but won't completely load.
It justs sits there.
I have tried many web addresses, but this is the only site that will fully load. (launchpad)

Question information

English Edit question
Ubuntu hal Edit question
No assignee Edit question
Solved by:
Robert Kryder
Last query:
Last reply:
Hanusz leszek (leszek-skynet) said : #1

Thanks for your question.
Could it be related to this bug: ?
try to type "sudo echo 0 > /proc/sys/net/ipv4/tcp_window_scaling" and see if it solve your problem

Robert Kryder (rrkryder) said : #2

I am getting a permission denied message, even when I type "/etc/sysctl.conf"

Hanusz leszek (leszek-skynet) said : #3

Did you paste the following line on a terminal and checked if it solved your problem ?

sudo echo 0 > /proc/sys/net/ipv4/tcp_window_scaling

Robert Kryder (rrkryder) said : #4

Yes, I did. Permission denied.
I am the administrator, and I am the only one who uses this laptop.

Philip Lowman (philip-yhbt) said : #5


Try the following instead:

sudo su -c "echo 0 > /proc/sys/net/ipv4/tcp_window_scaling"

or as three commands executed separately:
$ sudo su
# echo 0 > /proc/sys/net/ipv4/tcp_window_scaling
# exit

If this improves performance add the line "net.ipv4.tcp_window_scaling = 0" to /etc/sysctl.conf and reboot
sudo gedit /etc/sysctl.conf

Also, in case you're curious, the reason the "sudo echo 0 > /proc/sys/net/ipv4/tcp_window_scaling" fails with permission denied is because the only part of that command that gets run as root is the "echo 0" part which does nothing but print the number 0. The part that redirects the 0 into the file /proc/sys/net/ipv4/tcp_window_scaling gets evaluated with your normal user credentials which don't allow this since the file is only writeable by root.

Robert Kryder (rrkryder) said : #6

This did not help.
Still, the page I want, I.E. Google, will not load. The progress bar below goes all the way except for one square, none of the google page loads that I can see, and it just sits there. Yet I can access the launchpad website just fine.

Robert Kryder (rrkryder) said : #7

To Clarify: Launchpad is the only website I can access and move around in. No other web page will load.
Why would this have to do with windows scaling? Does the Luanchpad website not utilize it?

Best Robert Kryder (rrkryder) said : #8

I found the answer to the problem on question # 2570.
Here is the answer:

LarryCraig wrote:
This is solved. Simpler than I could imagine. In Firefox enter "about:config" Press enter to search. Double click the results (may have to enter ipv6 in upper empty line) to change Boolean logic from false to true. This is for those running on pppoe who don't need ipv6.

My internet is booming again.

Todd Smolen (toddsmolen) said : #9

The Launchpad website is not clear, massive confused, no guide here, how I know where the forums or make new question. I keep get lost in the website, It's need work on. Because I use be website design. Thanks.