Only 800x600 resultion on my Thinkpad

Asked by Fred on 2007-05-06

Hello,

Just installed Ubuntu 7 on my IBM Thinkpad A22p. Works ok but the best screen resolution is only 800x600 which is not good enough. Is it possible to get a better one?

Thanks for your time.

Fred

Question information

Language:
English Edit question
Status:
Solved
For:
Ubuntu hal Edit question
Assignee:
No assignee Edit question
Solved by:
Cesare Tirabassi
Solved:
2007-05-06
Last query:
2007-05-06
Last reply:
2007-05-06
Jesus Gamio (jgamio) said : #1

Can you show me the /etc/X11/xorg.conf ?

Fred (f-dubru) said : #2

# /etc/X11/xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf(5) manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
        FontPath "/usr/share/fonts/X11/misc"
        FontPath "/usr/share/fonts/X11/cyrillic"
        FontPath "/usr/share/fonts/X11/100dpi/:unscaled"
        FontPath "/usr/share/fonts/X11/75dpi/:unscaled"
        FontPath "/usr/share/fonts/X11/Type1"
        FontPath "/usr/share/fonts/X11/100dpi"
        FontPath "/usr/share/fonts/X11/75dpi"
        # path to defoma fonts
        FontPath "/var/lib/defoma/x-ttcidfont-conf.d/dirs/TrueType"
EndSection

Section "Module"
        Load "i2c"
        Load "bitmap"
        Load "ddc"
        Load "dri"
        Load "extmod"
        Load "freetype"
        Load "glx"
        Load "int10"
        Load "vbe"
EndSection

Section "InputDevice"
        Identifier "Generic Keyboard"
        Driver "kbd"
        Option "CoreKeyboard"
        Option "XkbRules" "xorg"
        Option "XkbModel" "pc105"
        Option "XkbLayout" "us"
EndSection

Section "InputDevice"
        Identifier "Configured Mouse"
        Driver "mouse"
        Option "CorePointer"
        Option "Device" "/dev/input/mice"
        Option "Protocol" "ImPS/2"
        Option "ZAxisMapping" "4 5"
        Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
        Identifier "Synaptics Touchpad"
        Driver "synaptics"
        Option "SendCoreEvents" "true"
        Option "Device" "/dev/psaux"
        Option "Protocol" "auto-dev"
        Option "HorizScrollDelta" "0"
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "stylus"
        Option "Device" "/dev/input/wacom"
        Option "Type" "stylus"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "eraser"
        Option "Device" "/dev/input/wacom"
        Option "Type" "eraser"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
        Driver "wacom"
        Identifier "cursor"
        Option "Device" "/dev/input/wacom"
        Option "Type" "cursor"
        Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
        Identifier "ATI Technologies Inc Rage Mobility M3 AGP 2x"
        Driver "ati"
        BusID "PCI:1:0:0"
EndSection

Section "Monitor"
        Identifier "Generic Monitor"
        Option "DPMS"
EndSection

Section "Screen"
        Identifier "Default Screen"
        Device "ATI Technologies Inc Rage Mobility M3 AGP 2x"
        Monitor "Generic Monitor"
        DefaultDepth 24
        SubSection "Display"
                Depth 1
                Modes "1600x1200"
        EndSubSection
        SubSection "Display"
                Depth 4
                Modes "1600x1200"
        EndSubSection
        SubSection "Display"
                Depth 8
                Modes "1600x1200"
        EndSubSection
        SubSection "Display"
                Depth 15
                Modes "1600x1200"
        EndSubSection
        SubSection "Display"
                Depth 16
                Modes "1600x1200"
        EndSubSection
        SubSection "Display"
                Depth 24
                Modes "1600x1200"
        EndSubSection
EndSection

Section "ServerLayout"
        Identifier "Default Layout"
        Screen "Default Screen"
        InputDevice "Generic Keyboard"
        InputDevice "Configured Mouse"
        InputDevice "stylus" "SendCoreEvents"
        InputDevice "cursor" "SendCoreEvents"
        InputDevice "eraser" "SendCoreEvents"
        InputDevice "Synaptics Touchpad"
EndSection

Section "DRI"
        Mode 0666
EndSection

Jesus Gamio (jgamio) said : #3

OK in the Section "Monitor" you dont have the HorizSync or VertRefresh. You need add this line with the monitor data

Do you know the HorizSync or VertRefresh from this monitor ? Caution Put a wrong number could be in a monitor damage.

Fred (f-dubru) said : #4

I beleive it is 60Hz

Shall I simply add these 2 entries in the monitor section?

HorizSync 60
VertRefresh 60

Ralph Janke (txwikinger) said : #5

No this does not sound right.

According to here: https://bugs.launchpad.net/ubuntu/+source/xorg/+bug/29540/comments/1, it should be

HorizSync 28-80
VertRefresh 43-60

I hope this helps

Jesus Gamio (jgamio) said : #6

I was looking for you I get this page

http://www.richardneill.org/a22p-mdk11-0.php

VertRefresh 60
HorizSync 31.5-90

Add these and reset the machine

Ralph Janke (txwikinger) said : #7

However.. I would make sure to look at the official specs!

Fred (f-dubru) said : #8

I just realised that I was not requested to set the root password during the OS installation. Is it a default password?

Thanks again for your time.
Fred.

Best Cesare Tirabassi (norsetto) said : #9

Yes, its your user password.

Fred (f-dubru) said : #10

Thanks Cesare Tirabassi, that solved my question.

Fred (f-dubru) said : #11

I have updated xorg.conf accordingly and added the correct resolution (1600x1200). Thanks very much indeed for all your help.

Regards,
Fred.